Change state of button not working

Feb 25, 2020

I really do not understand what is happening with the change state trigger.

It was working fine all last week up to yesterday, now this morning after disabling the button, then changing state to normal and jump to next slide after object trigger has occurred, it is not happening.  I have been using the same triggers for the past couple of weeks.  Why have they suddenly stopped working?

When I view it in Preview, nothing.  When I opened one of the Story files from last week (when the triggers were working), the same issue appears (change state triggers have stopped working) - even though the previously published files are correct.

I have updated to latest Storyline 360, working on my local drive, opened a new file, created a new slide and added the triggers but still no joy.  

As usual I'm up against a short deadline and really need a quick resolution.

Any ideas?  Below is a image of the triggers.

13 Replies
Erin Sadler

I don't see why it's not working - does seem like a bug. I just moved everything on that layer to a new slide and it works fine that way (copied and grouped your background image so you still get the fade effect, or you could do it with a slide transition).

Although I was getting 'can't run javascript' errors in preview, which is interesting when there appears to be no javascript >.<

Erin Sadler

Was the new slide JUST this text/button element that's on the new layer, or the whole slide? I'm just thinking it's misbehaving BECAUSE it's on a layer - not that it's any excuse, there's still no reason for it not to work. But moving the text field and button out of the layer and into a new slide worked for me.

Hope the reinstall helps though!

Tex Hale

Thanks for your input Erin.  

Brian, I had a brainwave yesterday!! I installed the December 19 version (3.35.21017.0) and now everything works perfectly as before.  Whatever was done to the latest February update appears to be the problem I was having.  

Because of this, I am unable to update Storyline and will have to continue working with the older version.  

Aside from this, I also noticed that when you use the built in graded questions, the Check boxes/Radio buttons are much too close to the question words, consequently you either have to create your own or insert a space between the Check box and the Question.  Is it possible to adjust this?  In the Classic mode this was never an issue.

I am still enjoying using 360 and everything you/team continually do to help us is greatly appreciated.

Erin Sadler

The question words or the answer words?

I always add a left indent on all my quiz answers because I don't like the spacing, how close the text sits to the checkboxes/radio buttons


If the answers are too close to the question, you can fix it by setting up the slide master. I always do this for every course I start because I don't like the default content positions!

Brian Allen

Tex, glad you've narrowed down the problem... 

I'm not on staff for Articulate, I'm a customer just like you.

You'll want to submit a case with the Articulate support team so that they can look into whatever was done in the latest update to make your project work incorrectly -

This discussion is closed. You can start a new discussion or contact Articulate Support.