Closed Caption Icon does not appear

Aug 10, 2017

Hi Heros!

When I play my storyline 3 file, the closed captioning icon does not appear.  I have the Captions Control checked in Player Properties. I also inserted a video and .sbv file with the same name that I created using YouTube's functionality.  When I Preview the slide with the video and caption file, the Caption Icon does not appear.  I tried creating a new file and tried it again and it is still not working.  Can you think of why the Closed Caption Icon does not appear?

34 Replies
Mike Adamski

I can confirm that 3 years later and using Storyline 360, this is at least sometimes still a problem.

I am happy to send along a file if I can do so privately as I cannot attach something publicly here, but even after creating a brand new text-to-speech file and ensuring CC is checked (and added into the player), it is not showing as even an option to turn on or off in the player once published.

Becca Levan

Hey there Mike!

So sorry this keeps happening to you, and great call on submitting a case with our Support Engineers!

I see that Gerald connected this experience to a potential bug in Storyline:

  • Behavior: Closed caption button disappears when the Pause timeline of base layer option is enabled in a layer
  • Workaround: Disable the Pause timeline of base layer option in the layer and use triggers to control the audio playback

Your post and case are linked to this issue’s report so we can notify you of any changes on all fronts. Let us know if you have any more questions!

Leslie McKerchie

Hi Mike,

As Becca promised, I wanted to let you know that we just released another update for Articulate 360 and included a few important fixes you'll see in the release notes.

The item you'll be interested in is:

Fixed: The closed captioning button disappeared when slide layers paused the timeline of the base layer.

Just launch the Articulate 360 desktop app on your computer and click the Update button for Storyline 360. Details here.

Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.

Jessica Moormann

I have the update, and I'm having this issue again. Previously I've fixed it by unchecking 'closed caption, saving, then rechecking - but it is not working this time. Here is my scenario:

I have a LONG video (almost two hours)

I have an srt.

The .srt file successfully attached to the video (verified by viewing when I go into 'edit captions'). In the edit captions view - it works perfect.

The CC icon appears in the player set up preview. 

The CC icon does not appear when I preview the slide, or project, or when I publish (whether to a file or Articulate Review).

I've created a trigger to default the CC to True - still, no captions show up on playback.

Leslie McKerchie

Hello Tracey,

Thanks for reaching out and sharing that you're running into a similar issue.

I want to take a look at your project file to investigate what's happening with your permission. You can share it publicly here or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

Nicholas Beech

Hi all,

I, too, am having problems with CC ever since updating to v3.54.25674.0.

There are two issues:

  • Firstly, the CC icon is not showing on published files or when previewing, similar to other cases in this post.
  • Secondly, when trying to edit captions, the dialog freezes and an error message is shown.

I've reported the second issue, but only discovered the first issue today.

Please see sample file attached.

Kind regards... Nick

Becca Levan

Hi Nicholas,

Thank you so much for sharing your file! I noticed that the Generate Closed Captions box wasn't selected in the text-to-speech audio file. Here's what I did.

Take a look at the attached file and let me know if you can see those CC icons; we'll go from there!

I've made a note in your case for the second issue, so one of our support engineers will follow up shortly and continue troubleshooting with you. That way, we keep all communication in one spot!

Nicholas Beech

Thanks, Becca.

I hadn't spotted that box. What also confused me was that I was able to go into the editor for captions and the text DID appear, even though the box hadn't been ticked. Anyway, with the Generate Captions box ticked, the published version now shows CC.

Thanks again... Nick

Katlin Shoemaker

I am also having this issue. Despite being enabled in the (modern) player and appearing in preview, the CC button appears and disappears sporadically after being exported as SCORM and uploaded into our LMS. It happens more in Chrome than in Firefox. Caption button will sometimes reappear when the page is refreshed.

Becca Levan

Thanks for reaching out, and welcome to E-Learning Heroes, Katlin! ⭐️

I'm sorry to hear that the Closed Caption button is causing you issues. We'd love to help!

First step: I'd recommend testing your course in a different LMS environment: How to Troubleshoot Your LMS with SCORM Cloud.

  • If your course behaves as expected, the next step would be to follow up with your LMS admin for a recommendation.
  • If the Closed Caption button is still misbehaving, connect with our support engineers to share your file, so they can help determine a cause.
Christine Ramirez

Hello. I'm having the same issue with the "cc" icon not showing when the project is published evn though it's displayed in the player. I used the Record mic option to record my audio, but the closed captioning icon is still missing. I haven't set up the closed captioning option yet, so I don't know if that's the issue.