Embed a movie from website

Hi all!

I tried the embed functionality in Storyline and used this embed code from the website:

<script type="text/javascript" src="http://www.brighttalk.com/clients/js/embed/embed.js"></script><object class="BrightTALKEmbed" width="705" height="660"><param name="player" value="channel_player"/><param name="domain" value="http://www.brighttalk.com"/><param name="channelid" value="534"/><param name="communicationid" value="69227"/><param name="autoStart" value="false"/><param name="theme" value=""/></object>

But Storyline does not want to accept it. When I enter the code in the box "Insert Video From Webiste" it gives me the error: "Storyline cannot insert a video from this embed code. Verify that the embed code is correct and try again."

So I adpated the embed code into: 

<iframe width="560" height="315"  src="http://www.brighttalk.com/clients/js/embedframeborder="0" allowfullscreen></iframe>

Storyline accepts the code now but the video cannot be viewed. Can anybody let me know what is wrong with the codes and how I should write them?

Thanks,

B

11 Replies
Christine Hendrickson

Hi B!

What's the actual link to the video? From the code above, it looks like it's trying to access "http://www.brighttalk.com/clients/js/embed/" and even when trying to access that URL manually, I see the error "File not found". 

When I try to access the link in your first code ""http://www.brighttalk.com/clients/js/embed/embed.js" all I see is text. It also looks like a JavaScript file call, not a video. 

If I try to insert the .JS file as a web object, it prompts to download the JS file, so I'm not entirely sure this is the actual file you're trying to embed. 

Can you provide a link to a video, instead? 

Thanks!

Christine

Christine Hendrickson

Hi B,

Looks like you have to register for the site, in order to view the video. So, I can't be certain how the video would be inserted. However, it doesn't look like the embed code for that video is public. I'm assuming that's different once you have an account. Is that correct?

First, I would make sure you have the rights to use this video. If you do, how about just creating a single video screen recording, in Storyline, of the videos instead? This would probably be much easier for you, if this is an option. 

Thanks B!

Christine

Spencer O'Hara

I have a similar issue. I'm trying to integrate videos into our content using the video streaming service Ooyala. They supply an embed code similar to the one from brighttalk, but Storyline doesn't recognize it as an embed code. 

OO.ready(function() { OO.Player.create('ooyalaplayer', 'BlOTk0azq4i1zwnAAah9AeepOg9UcLgg'); });
Please enable Javascript to watch this video

When I test the code on JsFiddle.net, it recognizes it as an embedded player and video.  This portion of the code refers to the video ID (video link) that the player url calls up. 

{ OO.Player.create('ooyalaplayer', 'BlOTk0azq4i1zwnAAah9AeepOg9UcLgg')

Any assistance with this issue would be great!

Thanks, 

Spencer

Christine Hendrickson

Hi Spencer and welcome to the community!

It's been quite a while since B first posted this question - I'm not sure if he's still subscribed. You might want to try sending him a private message to see if he was able to get this working with that code.

If not, I would recommend starting a new thread with the name of the video provider (Ooyala) in the title. Perhaps others have used this and can give a little advice on how to insert the videos with the coding they provide. 

Let us know if you find something that helps :)

Thanks!

Spencer O'Hara

Chistine, 

I modified the embed code with limited success: 

"<iframe height="360" width="640" webkitallowfullscreen="true" frameBorder="0" src="http://player.ooyala.com/iframe.html?ec=BpOTk0azohNVAGgSyh3wePk04t1KzJ98&pbid=4b64ab1aed2c4649beef772159ceadde&docUrl=www.ooyala.com"></iframe>"

This code worked for about 5 minutes, and all the sudden it stopped working. Now, when I insert the embed code, the video placeholder shows up for 2 seconds, then turns blank white (instead of of grey with the text "video". ) When the video worked, the grey placeholder remained grey and didn't turn white. I've been using the same embed code as i did before - but now it simply doesn't work. 

Now, no matter what I seem to try, the embed code doesn't work.  Help? Why is it so difficult to embed videos within Storyline? 

Spencer O'Hara

Ashley, 

I've tested the embed code from a different network, and that didn't work. I also attempted to repair Storyline, but when I "run as administrator" there is no option to repair the installation, just to add/remove storyling programs,  Reinstall, and Remove all. I tried to "reinstall". 

After reinstalling and rebooting my computer, the issue still persists. After 3 seconds of inserting the embed code in the Storyline slide, the grey video placeholder is replaced by blank white. 

Any other suggestions? My next course of action is to try Storyline on a different computer.  It puzzles me why it was working fine then all the sudden broke.