Enter key in Data Entry not working

I am recording the screen of my application using SL 2.

There are steps that require the user to type in a response.

I inserted the recorded screen in Try Mode.

In the published state of the course, after entering the response (text) to the data entry field and pressing the Enter Key, it does not go the the next step of the simulation.  

Is this a bug?  

The triggers of the concerned slide is straightforward and looks correct.

I hope that the community can help me on this pressing concern.  I am trying to finish my project in 2 days.

Thank you for the attention.

 

18 Replies
Ashley Terwilliger

Hi Caesar,

Here is how the enter key should behave within a text entry.  In regards to the browser, are you recording the screen in Chrome or just viewing it in Chrome? We recommend conducting any browser recordings in Internet Explorer or Firefox, as Chrome doesn't do as good of a job reporting information as a part of the screen recording.  

If you're still having difficulty, could you share the .story file so that we could take a look at your triggers and screen recording? 

Caesar Aycocho

Thank you for the reply Ashley.

The application I am recording runs only in IE. I published the course to CD format and ran the .EXE file.  I am using a Chrome browser.

There is no problem with the data entry field in the Preview mode. The problem arises when it is already Published.

Here is the project file (.story) as requested.  This is a work in-progress.

I hope you can help me.

Ashley Terwilliger

Hi Caesar,

Thanks for sharing the file here. I took a look at this and stripped it down to a few of the slides for data entry (just to make publishing easier) and the enter key worked as expected when testing the published to CD output in Chrome. It set the value of the data entry and showed if I answered incorrectly or if correctly moved me to the next slide. What are you seeing happen when using the "enter key" - does this happen on all slides or could you point me to a specific slide that is problematic? 

Caesar Aycocho

Hello Ashley,

Im glad to know that it worked on your side.  Sadly, I cant get the data entry to work for the correct and incorrect response respectively in Try Mode.  I published it again in CD format.

One slide where user is required to type something is shown below.

1 of 4 data entry interaction

When I type the description text (beside) for the Work Order and press the Enter Key, nothing happens.  It does not evaluate the text that was entered and show the corresponding feedback/ action.

When I click on another part of the screen, nothing happens also.

I am using SL 2.  Would it be possible to get a copy of the stripped down version of the project file you tested?  I really would like to see it working.

Thank you.

 

Ashley Terwilliger

Hi Caesar, 

Sure thing - here is the zipped output I worked on. You'll want to download to your local drive and then extract the files. I tested the story.html file in Chrome (your screenshot looks like IE?) 

Let me know how that one works for you. 

Caesar Aycocho

Hi Ashley,

Thank you for sending the project file. I unzipped the file and saved it on my hard drive.

As I mentioned, the app I am recording runs only in IE.  But I am viewing the published recording using Chrome.

Strange...

When I launch the course using Launch_story.exe, the data entry interaction does not work.  That is, the Enter Key does not work as expected.

But when I launch the course using Story.html, the data entry interaction works!

Why is that?

Ashley Terwilliger

Since the Launch_story.exe file opens it in a player that is built off of Internet explorer by default, I'm wondering if IE isn't allowing/accepting the enter key as submitting the interaction. I've seen some similar behavior with other keys such as backspace, delete, etc. in data entry fields when published for CD - since you're wanting users to access the course in Chrome, can you point them towards using the story.html file which they can choose to open in Chrome? 

Caesar Aycocho

Thank you for the reply Ashley.

Yes.  I have also experienced the same events in SL 1 not in SL 2.  I hope that these nuisances in the behavior of the Enter Key for data entry interactions will be addressed in the coming updates.

I have the solution for my concern already.  The screen recordings will actually be published and deployed in an LMS environment, ie Docebo SaaS LMS.  So I am assuming the data entry interactions will work. 

Right?

I was using the CD format to see that everything is in place and working properly.  This is not the format that the course will be deployed.

Ashley Terwilliger

Hi Caesar,

Yes, I'd expect it to work in your LMS, and when you're testing your content you'll want to publish and test within the intended publish environment so that you know how it'll work or how it's expected to work. If you're not ready to load up to your LMS yet, you could always test it at SCORM Cloud which is an industry standard for hosting and testing SCORM Content. 

Caesar Aycocho

HI Ashley,

Yes. Somehow I knew that I had to test it in an LMS but was lazy to do just that :-)

I will be more disciplined in testing my course in the intended publish environment.

I use tempshare.articutate.com for testing in an LMS environment.  I will also look at the SCORM Cloud.

Thank you very much for your support.  I will update you when I finally deploy the gold version to the LMS.

Success!

 

Mark McEvoy

Ashley,

I've tried and I've tried and I've tried, but I'm still having trouble with getting the Enter key to work. I've read a number of articles on the community site and was hoping that publishing to the LMS would prove that there really is no problem to be concerned with. I used SCORM Cloud as you suggested, and still the Enter key does not work with my text entry fields.

I've attached my working file for your review. It is a stripped down version of what I'm trying to create. You'll note that the first slide is a text entry slide that DOES work correctly in terms of the Enter key being used. I've noticed that it is when the slides are coming out of the Question Bank that the Enter key no longer works. In other words, if I take the same slides and put them into a scene, voila!, the Enter key works. So what's happening within the context of the Question Bank that stops the Enter key?!?

Any help you can provide will be appreciated. Thanks!