Entire Storyline player goes black when displaying multiple layers

Entire Storyline player goes black when displaying multiple layers

I am working on a 28MB file with 14 slides (some have multiple layers) in Storyline.  My most complicated slide has a base layer and 3 additional layers.  One of the layers has 33 objects at varying places in the timeline, including an MP3 sound object that plays throughout the one later, and additional sound objects for each additional layer.  When I preview the course, the problematic slide works just fine. Each of the 4 layers automatically displays one after the other, as expected.  When I publish the course, however, in between layer 2 and layer 3, the course "crashes". The slide and the whole entire player goes black. You need to open the course again to view the rest of the course.  

To fix it, I created a new slide with 4 new layers, copied all objects from each layer (in the old slide) into the corresponding new layer, then reattached the triggers.  I republished and it worked properly.  

Is there something I could have done to prevent this?  Was something corrupted or did I do something wrong? Thanks for your help and let me know if you need anything from me, or if this is a known issue.  

Thank you!!

Mary Ann

7 Replies
Peter Anderson

Hi Mary Ann!

It doesn't sound like you tried anything unusual or that would've pushed Storyline beyond its capabilities. We would have liked to have gotten our hands on that original file to explore it more, but if it happens again, will you send it over to us? We'd really appreciate it. 

Thanks Mary Ann, hope you have a great weekend

Leslie McKerchie

Hi Conor!

This thread is a bit dated. I was able to track down Mary Ann's case though and it seemed her issue was related to triggers applied to text boxes instead of the slide/layer and there was corruption.

Have you tried to import into a new file to rule out corruption?

Would you be able to share your .story file so that we can take a look at what you are experiencing?

Conor Bradley

Ok - we've had a look and managed to come up with a solution for our particular problem.

Originally we had a slide that effectively 'looped' by having a trigger that was set to jump to the slide itself at the end of the timeline. What we were seeing was that when the timeline ran out the entire screen just went black and the learner couldn't continue.

The resolution was to change the slide properties. The option for 'When revisiting' was set to 'Automatically decide'. Once we changed this to 'Reset to initial state' the slide 'looped' correctly and we didn't experience the black screen any more. Hope this is helpful to someone else!

Big thank you to Leslie for digging through the old case and resurrecting this thread!