Error in Preview and Publish

Hello,

I'm making a big system course with a lot of screen recording and presentations before the chapters to present the content to the user. I'm using one file for module.

Sometimes, when I try to preview it or publish it, I don't know why, the Articulate presents a error report saying: "We´re sorry, something went wrong with Articulate Storyline and it might close." And It wont let me publish at all.

Looks like my file is corrupted, but sometimes I can get it to work, by importing to one blank file or something like that. 

In other files, when I took out the presentations (made by Articulate itself, using only .png icons) i was abble to publish it. But on this one that I'm working right now...nothing resolve. Can it be a memory issue?

I didn't get it yet why this is happenning.

Ps: I'm already saving in local C: drive.

Can you help me?

26 Replies
Bex Hepworth-Sims

Hi

I'm having the exact same problem.

I'm also saving in my C drive and to try and resolve the problem, I have:

-  saved the file with a different name

- copied and pasted all the screens into an entirely new file

- asked a colleague to try to publish/preview the file from their C drive

And nothing has worked.

I'm not sure if I'll be able to share the file due to the content, but does anyone have any suggestions as to what I can do?

Thanks

Daniel Bolia

Hello,

I've been getting this same error when attempting to publish on SL3, see screen capture. The first time I got this error, I saved the file as a new file with different name and was able to publish. Now I'm seeing the error again and have not been able to resolve the issue. Is there any way for me to diagnose the problem? I've already used the Send function, although I'm not sure what this does.

Unfortunately I will not be able to share my SL file because it's very large and the information is proprietary.

 

Alyssa Gomez

Sorry you're running into that, Daniel! Here are a few things you can check before jumping into troubleshooting:

Let me know how it goes, and we'll keep digging!

Daniel Bolia

Hi Alyssa,

Thank you for the prompt response. Unfortunately the suggestions provided did not solve the problem. I'm working from a local hard drive. I've created a new SL 3 file with no scene or slide and imported my slides into the new file. Imported the Player.xml file to reset my player settings. However, after I make any changes to the course I get an error when I publish the course. Occasionally it would work if I change the Title. Other times I would have to reboot my computer and it might work. Very frustrating!

Any other trouble shooting tip?

Dan

Daniel Bolia

Hi Rebecca,

Thank you for the suggestion. However, I don't think that is the case here as I'm able to publish without the error as long as I change the title for the output publish file. Furthermore, I'm not experiencing this problem with the same slides, scene, file when I'm using SL2.

Frustratingly perplexing to say the least,

Dan

Daniel Bolia

Hi Wendy,

Thank you for the suggestion. By File Name I take it that you are referring to the name that the Storyline file is saved as. My file name consists of alphanumeric characters, mixed with spaces, underscores and dashes. For example, [ Project Name_Aug-25_ver-1 ].

I don't think my SL file naming convention is the problem. If I make any changes to my SL file, I will get the dreaded error when I try to publish. So far, I've been able to consistently resolve this error by using a different Title (in the Title and Location section) when I publish.

For example, if my last publish version has a title DanBolia_Aug-25, it will error when if I try to publish again without changing this title field. Simply deleting or appending a single character to the previous title name would allow me to publish.

For now, I can only hope that I can consistently fix this by changing the title before finalizing the publish process. I should note that I'm using a trial version of SL3 to evaluate the software. Perhaps this error is intentional so I that I will get frustrated and try SL 360.

Daniel Bolia

PROBLEM SOLVED!

With SL3, if the published output is open locally in the browser, SL will present the dreaded error when you try to publish again. The output file must be closed and not be opened in the browser.

I'm not sure if this is consistent with all browsers as I usually only test in MS Edge, IE, and Chrome. In this case, I've been testing on IE 11.

Bruna d'Albuquerque

Hi,

My previous problem was solved. When I imported the slides to a blank file (over and over again) I was able to preview and then publish.

But once more I have the same problem, only this time is on recording screen when I try to preview it: "We´re sorry, something went wrong with Articulate Storyline and it might close."

I have recorded three times, different things, and only one presented this message. It isn't any object or text box, or any other element, because I didn't add anything else on the slide.

Unfortunately I will not be able to share my SL file because it's very large and the information is proprietary.

Someone have any other idea?

George Cooper

I am having this problem in SL3 Windows 10 (with all the latest updates). I ONLY work on my Hard Drive.

Storyline 2 is fine, but whenever I try to publish a StoryLine 3 file I have to reboot 2 or 3 times before I can get past the dreaded error screen.

I have 20 or so SL3 files and it crashes on all of them. This only started occurring 2 or 3 weeks ago. I tried renaming as Burt.story to no avail.

Erin Flage

I am experiencing similar issues.  Running Windows 7 Enterprise.  Long time Articulate user (since Studio '09).  Upon installing SL3 I have not been able to publish or preview even a blank presentation.  This is affecting half of my team.  We have our internal IT as well as the Articulate Support team working on it and no one can figure anything out.

Those of you who had similar issues, was there anything that eventually solved your problem (or was it more of a corrupt slide/image issues.

This is the error report that is generated when the error popup comes up.

<?xml version="1.0" encoding="utf-16"?>
<ErrorReport xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
<FirstName></FirstName>
<LastName></LastName>
<EmailAddress></EmailAddress>
<MachineName></MachineName>
<HardwareId></HardwareId>
<Message>Object reference not set to an instance of an object.</Message>
<StackTrace> at Articulate.Drawing.DirectWrite.DirectWrite.a(LocalizedStrings A_0, String A_1)
at Articulate.Drawing.DirectWrite.DirectWrite.a(Font A_0, String A_1)
at Articulate.Drawing.DirectWrite.DirectWrite.a(FontFamily A_0, String A_1, String A_2)
at Articulate.Drawing.DirectWrite.DirectWrite.a[a](String A_0, FontStyle A_1, Func`6 A_2, FontCollection A_3, Nullable`1 A_4, Nullable`1 A_5)
at Articulate.Player.PlayerText.Fonts.Save(IPlayerService service, bwContent content)
at Articulate.Player.PlayerWriter.Write(IPlayerContentProvider contentProvider)
at Articulate.Design.Publish.TargetContext.PublishBackgroundWorker.OnDoWork(DoWorkEventArgs e)
at Articulate.ComponentModel.STABackgroundWorker.a(Object A_0)</StackTrace>
</ErrorReport>
Crystal Horn

Hi there, Erin.  Thanks for sharing your experience so far with the community.  It always helps when other users can find common denominators.

I saw that Victor made some recommendations to you in your support case:

...please try to remove unused/unneeded application from your machine along with registry keys that points to those applications. Then, reinstall Storyline 3 and see how it goes. I also highly recommend installing any pending Windows updates if there's any.

How did you make out with those steps?  You can let me know here, or reply back to the case.  I want to make sure that you get the support you need to get back to normal!

Erin Flage

Hi Crystal,

Yes after Victor and I had a web conference, I uninstalled any unnecessary apps, cleaned my registry, and verified that there were no pending updates.

Our local IT is trying SL3 on a brand new re-imaged machine, but I will be very disappointed if we all have to re-image our machines just to get SL3 to work.

In searching on "DirectWrite" I saw that this is part of the DirectX and that there were updates to DirectWrite in DirectX 11.1.  However, my graphics card does not support that.  I am checking with others in my team that are able to run SL3 and see if that might be a difference between machines.

Thank you!