Formatting options on data entry field

Hello,

I have a slide with several numeric data entry fields on it, and I am finding that formatting options are ignored, or they are applied, but don't 'stick'.  For example:

  1. I select some text entry fields, and click the 'center text' option on the Home menu.  This appears to work.
  2. Next I right-click and choose Format Shape (still with several entry fields selected)  I set my text box options as I wish - Shrink text on overflow, 0px margin on all sides, wrap text OFF.
  3. I preview the slide and enter text in the text entry fields.  If I enter too many characters, they simply scroll off the left of the field, and I can only see the last few characters that were entered.  (these are very small - users are only expected to enter 2-3 characters in each)

Since the autofit options are clearly not working, I try to resize the text.  When I do this, the text is magically left-aligned again.  When I reapply the alignment, it sometimes sticks.  Sometimes simply clicking on the field is enough to change the alignment from centered to left-aligned.

So my question is this:

Can I apply autofit and alignment options to data entry fields, and if so, how?  

Bonus question:  why might this NOT be working for me now?

Thanks!

Terry

11 Replies
Phil Mayor

Formatting changes because of a bug, the best way is to set the format and then lock the object on the timeline, it often changes formatting when you click back in it

Autofit does not work on data entry field, it would be nice in the future to be able to limit the text by characters to stop this working.

Diana Myers

@Phil - THANK YOU, THANK YOU, THANK YOU!!!!

Your tip completely saved my bacon, along with countless hours trying to fight with lots and lots of numeric-entry fields!!!  I hadn't thought of locking the objects, and was originally worried that it would prevent the user from clicking and entering in the box, but your solution worked like a dream.

You. Are. AWESOME.

 

Paul DeHorn

Yes, many thanks Phil. Hero is an appropriate moniker on this day. I was having difficulty getting the formatting to "stick" on a text entry field. Locking the object worked. I love this community as I'm always able to find an answer, either based on someone's past experience or a direct reply to a question posted.

Javier Gonzalez

Hi all,

I'm going mental with the text entry formats... I'm working on a Fill-in-the-blank graded slide, but I can't change the 'Type your answer here…' format. It shows with the selected format on design view, but when I preview it keeps setting it in smaller font. Then once you click and start typing, it gets the selected font size again. I just want it to have the same format after and before you start typing the answer. This object don't have states to edit as other objects do, so I am out of ideas of how to solve this problem. Attached screenshot.

Thanks in advance!

Ashley Terwilliger

Hi Javier,

There are a few known issues in this thread with text entry font size, and without seeing your particular file I can't say for certain that it matches one of those - but if you'd like to review and let me know I can associate this thread with the report filed with our team or if you'd like to share the .story file here I can double check it as well. 

Christie Pollick

Hi, Javier -- So sorry to hear you are experiencing difficulties! If I am understanding your issue correctly, just highlighting the 'Type your text here' is how you'd format that, so I am not sure why yours would be changing. You may want to import the file into a new file, and also review this information on Unexpected or Erratic Behavior to see if you find improvement. 

If issue persist, you are welcome to share your file and we'll take a quick look. :)

Paul DeHorn

Hello Javier, you a not alone in going mental with the text entry formatting. It's an incredibly unstable and frustrating feature in Storyline 2. It’s too bad because I love Storyline, but this, along with some of the other simulation bugs/limitations, is slowly pushing my client back toward Captivate. I was able to reproduce your issue on my system. Unfortunately I don’t have a fix for you, but thought I’d send some moral support. I use text entry in a different manner. I start with an empty entry field with the cursor blinking (this has its own challenges and work arounds). But good luck. If there is a fix, the Staff and community are usually quick to respond.

Diana Myers

Hi Javier, I'm sorry you're having problems with the formatting.  I used multiple numeric entry boxes on a slide and had something similar happen.  

Have you tried formatting the text entry box and then "locking" the object on the timeline as per Phil Mayer's tip above (one of the initial suggestions on this thread)?  

The other times I've come across this problem is when I've copied and pasted a text entry box.  Something goes "hinky" with the entry box and it's related variable, and I had to delete and rebuild the associated variable for each box that I copied.  When I did that and locked them in the timeline, everything worked as expected and the entry boxes kept the formatting as intended.

Hope this helps!