How to hide navigation without causing player jumping

Hi all,

I'm having a problem where I want to hide the navigation on certain slides but if I turn it completely off, the player jumps as it goes from navigation to no navigation. So then I tried putting a trigger on certain slides to hide navigation when the timeline starts. It works (no jumping) but I can still see the navigation briefly while the page loads. Then it disappears. So THEN, I thought I would just have a trigger to set the navigation to be disabled, and make the disabled state white. But I can't see how to do this. Also, this still might not work--I might still get the brief flashes between slides. If anyone has any ideas on how I can hide the navigation without causing the player to jump--I'd be so appreciative!

9 Replies
Wendy Farmer

Hi Noelle

Without seeing your file it's hard to say but have a look at this sample.  I've created a master slide layout that hides the Prev/Next buttons on timeline start.

In the module I have four slides - two have the normal layout applied where the Prev/Next are displayed and two are based on the layout with the hidden trigger.  Of course the user in my sample has to use the menu to navigate the slides where the buttons are hidden but I'm not seeing any jumping - unless I misunderstand what is happening.

I've attached the file and here it is in Review 

Noelle T

Thanks so much, Wendy. I think the player is staying in place and not jumping because you have the audio icon visible on the bottom. If you remove everything from the bottom the player jumps down to the empty space, then back up again when the navigation returns. So... a quick fix might be to just put the audio icon in there (even though I don't need it).

OH and your method of hiding the navigation on the master slide may have my problem of it briefly showing up and then disappearing again.

Noelle T

The problem is, if I show the navigation and just disable it, people start complaining that the navigation doesn't work. Showing the volume icon works... but I wish I could change the colour of it to hide it. I have a fade transition on my slides and hiding the icons is not working as they show briefly while the fade is happening and then disappear. Very frustrating.

David Schwartz

Hi Noelle,

Do you have the option of going with custom navigation, and hiding the player entirely?

This would make it much more seamless. If you must have volume control, it would be tricky, but the rest is more straightforward.

Here's some good info on this approach: https://community.articulate.com/series/74/articles/storyline-360-user-guide-how-to-hide-the-player

Here's one approach to the volume control (I have not investigated this one): https://community.articulate.com/discussions/building-better-courses/add-a-custom-volume-controller-in-articulate-storyline-3-or-storyline-360