Imported movie files, aspect ratio wrong

Hi all. This isn't really a Storyline question but I know lot's of smart people follow this forum so I though my chances of getting an answer here would be high. I know, a bit cheeky...

I'm converting a whole lot of wmv files into flv and then importing them into Storyline. My problem is that when I convert the file to flv it's aspect ratio changes and the output is squished up.

I've tried using Articulate Video Encoder and Any Video Converter, but they both produce the same result despite having the output size set to "original". I suspect the wmv has some proprietary codecs (it's from Japan, 16:9 aspect ratio) as I've installed every codec under the sun and Articulate Video Encoder still won't play it. 

Any ideas? I can still use the files in Storyline, but I'm having to re-stretch each one back to its original aspect ratio after its inserted into each slide. Thanks.

3 Replies
Steven McAneney

Just thought I'd provide some follow up on this.

The original video was 3:2 aspect ratio, which I didn't realise at first. My video editing tool, Cyberlink PowerDirector, only works with 4:3 or 16:9, so even with the relatively good software I was always going to have difficulty. 

After hours and hours of playing with output settings I finally settled on the following solution:

  • Stretch the 3:2 aspect ratio to fill out the 16:9 canvas in PowerDirector.
  • Output the files to 1920 x 1080 resolution (16:9) mp4, so they have to be "squeezed" into a smaller canvas when imported into Storyline.
  • Set the Storyline canvas to 16:9 (720 x 405 px).
  • Import the mp4 video files into Storyline. they automatically resize correctly, however there is a small amount of 'letterboxing' on the left and right of each video. I am masking this using a gradient graphic sitting on a layer on the slide master template.

This workaround took me all of 9-hours to get to!

The moral of this story is: Make sure you are working with like aspect ratios!

I hope this helps someone.