Jump to slide x buttons not working

Hi guys,

We are working on updating a master file which we use to create courses. Unfortunately for some reason our trigger to jump to different slides isn't working while we haven't changed the triggers while previewing. For this example only section one should have a working trigger to go to the correct section. I also tried to publish it as web, but this also gives very mixed results. 

Even weirder is, I have added a rectangle and added the same triggers as the section one button. The result, it worked once while previewing. After that it didn't work anymore. 

I removed that rectangle for this example. Any help would be appreciated. 

Edit: This is while working in SL2

6 Replies
Noel Read

Hi, I have taken a look at your story but it's hard to work out what it is that isn't working (probably because I don't speak Dutch). If you can provide the name of the scene and the names of the slides the next button should go from and to I can take a look. Also, if there are any conditions that need to be met before the next button is enabled or visible. I can add in a trigger to go to the next slide when the next button is clicked and that works fine, but I'm not sure if this is what you are after. Noel 

Shane Hille

Hi Noel,

Thanks for the reply and sorry about the Dutch! So the problem is in the opening scene we have the menu slide with all the buttons towards different sections. When we try to move to section 1 using button 1 nothing happens (it should move to "hoofdstuk 1", without using the jump to next slide trigger as we are going to have 16 sections (hoofdstukken)). 

We use H01 as a variable to make sure the student will either move to the start of the section (false) or move to the end of the section (true). H01 is set true at the end of section 1. 

We also want the state of the buttons on the menu to change to goed (good) or fout (bad) depending on the score (hence the triggers with the score / passpercent).

The only thing I can come up with is that we are using PNG for the section buttons on the menu slide but then we still should be able to move to the pointed out section if we would click on the colored area. But nothing seems to work whilst previewing. 

The added rectangle I tried earlier had the same triggers as the section 1 button. While previewing it first worked and jumped to the page. I tried some more with the section 1 button, changed nothing about the rectangle and that stopped working too after a couple of previews.

Also when I changed the appearance of the section 1 element (vragen 1) to the start of the timeline it worked again, one time. Next preview it stopped working again.

Something just feels very strange about this whole situation to be honest. Maybe a corrupt file?

Noel Read

Hi, thanks for the info. I tested it and it works as I think you want it to (I've attached a vid of what it did). But I am using SL3 so maybe a technical issue with SL2 or the file, that was corrected when upgraded to SL3. Might be worth raising it with the technical team here to see if they can find the issue. Good luck! Noel