No Javascript working - feeling anxious!

Hello Storyline gurus! I've been searching for days to find a way to allow users to print the results of a set of questions we're asking them to help develop an account plan. I've found several that seem like they should work fine, but I can't get ANY JavaScript to run. I've tried it using Tempshare and our LMS but NO JavaScript will run! My actual course is a bit long, so I've got a small sample that I'm uploading to test it. I've included several different buttons on the final page because I'm trying different methods, but I've also tried eliminating all but one at a time to see if there's a conflict or if one or more has an error.

Naturally this is supposed to be published to our audience TODAY so if anyone's feeling super speedy in responding, 1000 internets to you!

8 Replies
Jackson Hamner

Here is a copy of my JS to open a new window.

var newWin=window.open("", "TEST", "status=0,scrollbars=0,width=820,height=620");
var contents="<HTML><HEAD><TITLE>TEST</TITLE></HEAD><BODY><h1>TEST</h1></BODY></HTML>";
newWin.document.write(contents);

I don't know exactly why yours isnt working, but i know my JS wouldnt run when I didnt publish the course with the 'Use articulate Mobile Player for iOS or Android / Allow downloading for offline viewing' checked. Once it was checked the code above worked perfectly. 

Hope this helps some!

 

Cédric Mallet

Running a debugger on the generated files show that the JS file user.js is corrupted (in the end all the JS code ends up in the same file).

You should remove the <SCRIPT LANGUAGE="javascript">

Also there seems to be a line looking like this,  which Chrome debugger calls illegal, likely do to the "~":

var header = “Business Imperatives - Driving Growth and Business Performance Discussion Guide~~”

Good luck!

Lori Greenberg

SO excited to have a reply! Thanks! Will simply deleting the user.js file cause Storyline to create it again? I've published and republished several times and it's never working, but if that's the reason it sounds like a relatively easy fix!

I really appreciate your help and I'll let you know if I have some success!

Cédric Mallet

Hi

Just deleting the user.js file should not help, it is recreated each time you publish the presentation. You need to find the triggers which bring those code lines and remove them.

Generally speaking, my way to work this kind of issue is to cut in the presentation (remove other slides, half the triggers, ..) until the problem disappears. Then you get the culprit :) 

Also beware of the browser cache when testing / refreshing locally (Chrome: Ctrl + Shift + R)