Problems When Quiz Timer Expires

We are currently publishing quizzes in Storyline 2. These quizzes have a set time limit.

The way we have our quizzes set up, there are multiple sections, with each section having its own results slide (hidden).
At the end of the quiz, a final results slide is shown. On this final results slide you get a message stating whether you passed or failed, and it displays a section by section summary that is pulled from the other hidden results slides.

EX:
You failed. 60%
Section one: 1 of 4 correct
Section two: 3 of 3 correct
Section three: 2 of 3 correct

Now on to the problem.
When someone runs out of time, a popup appears: "You have reached the time limit set for the quiz. Press OK to continue."
Upon pressing OK, the user is shown the last sections results slide (which is supposed to be hidden and never be displayed), regardless of which section they are currently on, as opposed to the final results slide.

Ideally, once a user has run out of time, they'd be sent to the final results slide.

I've found a workaround for this by just immediately jumping to the final results slide if any of the hidden results slides are accessed. But I feel like this shouldn't be necessary.

We weren't sure if this was a bug or not, so figured I'd report it, and see if anyone had a better solution.

3 Replies
Christie Pollick

Hi, Eric -- Thanks for reaching out and sorry to hear of your troubles! We appreciate that you have shared the workaround you discovered, but I did want to let you know that it looks like you have shared the published output folder instead of the .story (or source) file itself.The .story file would be best to share if you'd like others to check out the current set up of the file and share their insights. 

Christie Pollick

Hi, Eric -- Thanks for your reply! Unfortunately, when you reply to a forum notification via email, any attachments you intended to share do not come through to the post to be accessible by others. If you would like to resend, please click here to be taken to the post itself and then use the grey ADD ATTACHMENT button in the bottom left of the reply box.