Publishing issue with this one file.. ah!

Eventually I'll be publishing this story to an LMS but while the subject matter expert review it before it's in our LMS, I always just publish it for web and throw it on my dept's sharepoint site. Never any problems. Well I had a rough draft on our sharepoint site for the SME to review and they wanted a few tweaks made. I made those tweaks and then tried republishing it and re uploading it to the same site. I'm now getting an error saying "ERROR: Could not load the file 'story_content/data.swf' when I click on the file. I've tried republishing that version, as well as opening up the previous .story I have that was the 1st version I published to our SharePoint site for the SME and now I'm getting the same error. I even tried importing the file into a new storyline file and still got that error.

 

I then tried to publish a different file that I finished yesterday and that published perfectly fine.

 

I sent my file to a friend at a different company who has Storyline and my file publishes fine for her. She tried publishing it and sending me the output published files and I tried uploading those files to my SharePoint site and I'm getting the error again.

 

 

So... my file works for someone else but not for me BUT other files work for me on the SharePoint site. I'm so confused!! Any ideas?!

4 Replies
Ashley Terwilliger

Hi Gloria,

When are you seeing the error message? While publishing or when you upload to Sharepoint? Have you ensured that you're following the publishing guidelines here in terms of file name, path, and location? Also can you confirm that you're uploading the entire contents of the published output to your Sharepoint site? 

Macy Frost

Hi Ashley,

 

Thank you for trying to help!!

 

 

I'm receiving the error message once trying to view the file from SharePoint (SP). No errors during the publishing process nor during the uploading-to-SP process. Once I click on the link after it's on SP is when I receive the error.

The entire contents are being uploaded... the folder titled "story_content", the meta.xml file, the story.html file, and the story.swf file. (Not publishing for media viewing or LMS or anything else this run through so it's only the story_content folder plus the three files outside the folder.)

The published files came from a .story file I saved to my local drive (desktop), not a network drive, has a short name, etc. The error message makes me think not everything is being uploaded but I'm literally taking EVERYTHING that comes out of the publishing step.

 

(And I created a storyline project today that published and uploaded to that exact same folder just fine. I'm so confused! )

Ashley Terwilliger

Hi Gloria,

You mentioned your file worked for someone else - were they able to upload it to Sharepoint? Or what element worked for them that didn't work for you?

I'm not incredibly familiar with Sharepoint and their upload steps, but you'll also want to ensure that the folder and file structure of the Storyline output remains the same. It should still all be in it's main published output folder unless Sharepoint determines otherwise. 

Have you tried accessing the output from different browsers to see how that behaves?