11 Replies
Emily Ruby

Hello Mischelle!

Have you tried to make any other files in SL 2 with a quiz results page? Or is it only the file that was upgraded that you are seeing issues with?

Please make sure you are working locally as described here.

You can try to import your file into a new storyline file to see if this helps correct the issue.

You could also upload your file here using the paperclip con if you would like us to take a look.

Ashley Terwilliger

Hi Mischelle,

I'm assuming nothing else has changed from the version in SL1 and that it all worked as expected? 

Can you confirm that you're working with local project files in SL1 and SL2 as described here?  Also, have you tried importing the new SL2 project into a new file to see if it resolved any of the odd behavior? 

Mischelle Walters

Ladies,

Sorry for the delay - projects, projects everywhere!!!   I am working from my local drive. I don't have it in any other format than SL1 as I made it directly there.  

I just imported the file again and I think I got the results page to work, there are a few other issues I need to fix but at least that worked!!!  

Mischelle Walters

Emily, 

Unfortunately it didn't work!!  I think I have figured out the issue but don't know how to correct it.  When I am in the form view, in the ribbon for question - the Results Slide drop down: I am not able select " results slide".  This is a screen shot of what I am referring too. If I click on the "2.3 Results Slide"  it automatically goes back to "None", it will not stay selected.  Thoughts? 

Emily Ruby

Hello Mischelle,

I took a look at the file, and i did see that the Passing score text box and the actual score text box were hidden behind 2 objects you had added to the results slide. I moved them forward to be visible.

Also, the trigger to show the success/failure layers were not assigned to any variables.

Attached is the file with the triggers/ variables updated.

Hope this helps!

Mischelle Walters

Emily, 

In that same file there is a "pick many" question - slide 1.10 - I can't get that to work for me either.  What I am trying to do is have the user select the correct answers and display either a correct or incorrect layer depending on what they select.  Selecting choices 2 & 5  should display the correct layer.  Any other combination should display the incorrect layer.  I can't figure out how to get this to work.  Can you help? 

Emily Ruby

Hello Mischelle!

In order to have a layer show for an incorrect/correct in a non graded quiz slide, you will need to set up triggers to show these. You can use a custom button on the slide for this.

You will need to trigger to "show layer" on condition the correct responses are in the state of "selected"  and for the incorrect one, you will need to trigger to "Show Layer" on condition that the correct responses are not selected.

if this does not work for what you need, i am sure other in the community may have different ideas to share.