Screen freeze when jumping to a previous slide

Hello,

We've been having some trouble today with courses crashing when we click a 'previous slide' button.

Here's our set up...

1. The user is presented with a data entry box. Once they have clicked on it, a button appears (trigger: change state of 'button' from 'hidden' to 'normal') so that they can submit their response.

2. A new layer is shown, revealing feedback, with a button to proceed to the next slide.

3. When we then try to return to the previous screen, using a 'jump to previous slide' trigger, the course freezes.

We have managed to work around this issue by removing the 'change state' trigger from the data entry box in step 1. The 'submit response' button now appears whether the user has entered text or not.

This works okay, but we can't see why the trigger has caused this problem. We think it may be due to the .story file having been upgraded from SL1 to SL2.

What do you think?

Also, the 'type text here' text is very small when published. I can't seem to change this (although the user's text is normal).

I've attached a sample file.

Thanks,

Ross

 

10 Replies
James McLuckie

Hi Emily

I work with Ross, and I'm sure he won't mind me jumping in here while he is on holiday. 

Thanks for taking a look at the file. The "Go to 9.4" button doesn't really effect this issue. The screens Ross provided have been extracted from a scene. The "Go to 9.4" button in the original file is set up to take users to a completely different scene in the project, hence why the trigger was missing in the project file you've got. 

I have downloaded your file and I still get the issue with the project freezing if I complete the interaction fully on screen 1, and then use the "Previous Screen" button to jump back to it from screen 2. 

This seems to be a very, very specific issue with projects:

  • being converted from SL1 to SL2,
  • that have text entry boxes, 
  • that have an additional trigger applied to the text entry boxes other than the default "set entry to typed value" (in this case, a change state trigger)
  • there is a layer revealed
  • the learner leaves the screen with the layer having been revealed
  • the screen is set up to "resume saved state"

We tried various combinations here, such as having the learner returning to the base layer rather than the revealed layer, removing the additional trigger from the text entry box etc. These all meant that the "Previous Screen" button worked ok again. 

It's clearly a bug and a very specific one. And, in our case, a rather time consuming one as we've just converted around 1,000 screens from SL1 to SL2 and at least 100 of them are affected by this issue. 

Thanks

James

Emily Ruby

Hello James,

I was able to see the issue after letting the media and animations all play through. I did notice that the timelines were all set to over 900 seconds, and the trigger to jump to previous slide was not saving properly. You can click to edit it, but then it would revert back to being unassigned. I then tried to import the file into a new file and upon import, it crashed my Storyline. I tried a second time and the same thing happened. It seems the file itself may have been corrupted. You may want to reach out to our support engineers to see if they may be able to take a further look into the file itself.

Rebecca Carter

Hi everyone, I know this thread is years old but was wondering if the issue was ever fixed?

I am having the same issue right now with exactly what James listed above, the slide seems to be corrupted in some way and crashes the whole course when I click on the custom 'back button' to return to the previous slide whether its in preview mode locally or when it is published and uploaded to our LMS.

The slide I am having a problem with comes immediately after a slide that:

  • that has a text entry box
  • that has an additional trigger applied to the text entry boxes other than the default "set entry to typed value"
  • there is a layer revealed

It's really strange as it only seems to be malfunctioning on one slide.

I read loads up about suspended data yesterday as I had word from some of my users that the course wasnt saving their progress when they came back to it, so I spent the entire day stripping the course back and deleting unnecessary  objects, states, layers, triggers and made sure that no slides are set to resume state. This seemed to fix the issue of the LMS not saving their progress but the issue with the corrupted back button still seems to be here.

Apologies for the long confusing explanation!

Thanks for any help anyone can offer,

Rebecca