SL 360 Closed Captioning Bug - disappearing CC

On several of our recent projects, all of which are on current version of SL 360, there is a bug in the CC. The CC is added, time-edited, and saved. Going back into "Edit Closed Captions" reveals that CC bubbles are randomly empty. In two projects with hundreds of CC bubbles there were 30+ empty bubbles. All in the correct position, but empty.

21 Replies
Leslie McKerchie

Without seeing your project file, it's hard to understand what you may be seeing. 

A quick search is not turning up any similar sounding reports.

You mention editing the time, so perhaps check the milliseconds as we've seen an issue in the past surrounding that setting and this is the solution:

It looks like the timecodes in your caption files are incomplete. They should have milliseconds in this format: 00:00:00,000 (where the comma followed by three digits are the milliseconds). 

Here's how you can quickly fix the issue: 

1) Open each caption file in a caption editor or a text editor (such as Notepad). 

2) Add  ,000  to the end of each timecode. 

3) Save and close your caption files, then import them into Storyline again.

Alyssa Gomez

I'm really sorry this is still plaguing you, Jon! Can you verify a couple of things for me?

  • Are you on the latest update of Storyline 360? To check, click the Help tab, then click About Storyline. You should see 3.20.16814.0 in the bottom-right corner. 
  • Are you working from your local hard drive, or is the file saved to a network drive?

I know you mentioned you cannot share your file for proprietary reasons, but since it's the best way for us to demonstrate the problem and document a defect, we'd happily accept a .story project shared here privately if you change your mind.

Leslie McKerchie

Hello Anh,

I took a look at the case Jon worked on with our team, but it looks like we did not hear back from him on the issue.

Are you using the 'Undo' option when you are experiencing the empty captions? 

Are you able to replicate the behavior in a new file or is it just an issue in the current file you are working on?

Mai Anh

Hi Leslie,

Thanks so much for your reply. 

I've replicated this problem on some projects that I'd worked on, and I'd to retype the captions on the empty bubles. I'm worried about it because I don't know where the issues come from.

When I published the project on Review mode, it seems ok, but when I'm back to my files, I experience these empty captions. I don't use the "Undo" option.

 

Katie Riggio

Hi there, Anh. Appreciate you confirming those details!

Like my teammate, Leslie, I'm not finding reports where we have logged this oddity as a bug yet. Considering you ran into the same behavior as Jon, we'll need to investigate this further.

Could you share one of the troublesome .story files with us via this link so we can have a close look? If this is a bug we can recreate, we'll get it reported right away so we can begin looking at next steps. Looking forward to helping!

Ritesh  Ojha

Hi there,

I'm currently facing an issue related to the Caption button. The base layer of my activity doesn't have the audio but slide layers do have. Caption button isn't appearing in the slide layers also. This issue is coming since i have updated the latest version of storyline 360(v22). This issue was not there in update v21. Help me out. I've to deliver the course to the client ASAP.

 

Regards,

Ritesh Ojha

Alyssa Gomez

Hi Ritesh,

I'm really sorry you ran into that problem! We're seeing an issue in Storyline 360 Update 22 where closed captions won't appear if the audio or video is on a slide layer. 

Until we get this sorted out, you can try rolling back to Update 21 -- here's how.

I apologize for the trouble this caused you. As soon as we get this fixed, we'll let you know!  

Ashley Terwilliger-Pollard

Hi all,

I wanted to share a quick note about today's update to Storyline 360, build 3.23.17480.0. It fixed an issue a few of you were running into where in some cases, closed captions were missing when audio or video was on a layer.

Let us know if you run into any trouble with that update! 

Lauren Connelly

Hello Chris!

Wow, thank you for bringing this to our attention! Sorry for the hassle! Here are three questions to get us started troubleshooting:

  • Which version of Storyline are you using? Are you on the newest update? We are currently on Update 33 (Build 3.33.20697.0).
  • Is this occurring in every project or just this one?
  • Have you tried to copy and paste the text from another document like Word, Google Docs, etc?

If you can share your file with us that would be helpful too! You can do so by using the "add attachment" button in this discussion. Or you can share the file privately with our Support Engineers by using this link.

Jon Schiedermayer

Sorry to hear about it Chris, this does still happen to me on occasion, but not very frequently (I hope - I don't know that I am always catching it, because I've worked on a high volume of eLearning in the past year).

Edit: After watching your vid I can see that you are using a similar method to me and the other users at my company: copy the text to notepad to remove formatting, copy from there to SL CC. In theory, that text copied from Notepad should not have formatting and should not cause issues. How strange. I hope they can figure this out for us.

Lauren Connelly

Hi all!

We aren't seeing this bug where the undo button isn't working with closed captions, specifically in Storyline 360 (Build 3.49.24347.0). If you're still running into this snag, make sure you're using the latest version of Storyline 360. 

If you have any questions, don't hesitate to reach out to us in this discussion or in a support case.