SL Version 2 Install - Wishing I Hadn't

After upgrading to SL Version 2 I have a SL2 project with 3 weeks work into it and now SL2 has developed buggy behavior that is preventing me from completing it.

SL support has been timely but ineffective to date, and you can't get SL2 content into SL1 by ANY means .. tried them all.


Recreating this project from scratch in SL1 means weeks of wasted effort and an unhappy customer, an unhappy manager (mine) and an unhappy me.

For me it has been a HUGE mistake starting a project in SL2 ... should have stayed with SL Version 1.

I'm posting here in the desperate hope that someone, anyone, has "been there, seen that" and managed to resolve it?

Here are the problems:

1) Accessing the triggers dialog anywhere within a story locks up SL2 totally - only Task Manager can shut it down.

2) Some, not all, slide thumbnails quit displaying their content in Story View and Scenes Panel.

3) Object states goes from correctly displaying to perpetual "spinning wheel" graphic for every state of every object in the project.


This behavior is erratic and seemingly random. I can work for 5 minutes, 30 minutes an hour ... but it WILL lock-up.


Working with SL support, here's what been tried without success:

A.
uninstalled SL2
ran BAT file provided by support to finish uninstall
reinstalled SL2 (latest version)

B.
started new project:
imported scenes 1 by 1 from old project

C.
started new project:
imported slides 1 by 1 from old project

D.
started new project:
cut/paste slide content 1 by 1 from old project

E.
closed misc background and foreground programs (SnagIt, data backup, Outlook etc):

F.
ran SL2 under different user credentials, same PC, same domain/network

G.
installed SL2 on my personal laptop, not part of any domain or network

At some point I suppose I'll have to accept the inevitable and start over .. from scratch ... ugh. But it will be in Version 1. I would caution others that for time critical projects stick with Version 1.

12 Replies
Brian Allen

Hello Ken - pretty bizarre behavior... I've been creating projects with SL2 since it's been in beta and haven't experienced any of the issues you're describing.  What's even more bizarre is that it behaves the same way when you install SL2 on a personal computer?

Did you start your current project from scratch or did you start by importing a SL1 project?  Just curious...  Because SL2 acts the same way for you on multiple computers it seems as if it may be something related to your content (which is also weird...).

I know this doesn't help, just kinda scratchin my head a bit on this...

Ken Resner

Hi Brian & Emily,

 All head scratchin' on my end has ceased - we're all bald now!

I would agree that it does appear to be content related, at this point I'm leaning towards a corruption of content within my SL2 project that is not reversible. Unable to show current states of objects ... can't display contents of various slides in thumbnails views ... accessing Trigger dialog locks up SL2 so hard only task manager can kill it ... different user= same problems ... different  PC  = same problems. Any and all re-use of content, regardless of how it gets into a new file, seems to bring with it the same problems.

Bummer is there are dozens of objects, layers, triggers, imported pictures/graphics etc.  = 1,000's of possible combinations = finding the offending SL2  culprit is not feasible from a user perspective, maybe SL support have other tools to help in that area.

I'm just about resigned to starting over from scratch in SL1  ... as unappealing to everyone as that may be.

Bobbi Bailey

Ken,

When I updated to SL2 and then opened an SL1 .story in the upgraded version, they system automatically created a back-up of the SL1 version for me (filename - SL1 Backup.story).  Have you checked to see if you have the back up?

Also, when you updated to SL2, most likely, unless you manually removed SL1, both versions are still on your system.  You can easily launch SL1 and with the back-up, go back to where you were when you updated.

Hope you find a solution!

Bobbi

Ken Resner

Update, but no solution, from Support:

~~~~~~~~~

After checking the latest file you sent, I was able to reproduce the issue. Slide 1.8 hanged when I tried to insert a trigger.

 

We have reported this issue to our Quality Assurance team for their review. I cannot offer a time frame for when or if this issue will be addressed. However I will update you if I ever get any information on this.

~~~~~~~~

After 4 days of trying to debug this project with dozens of slides, dozens of layers and hundreds of objects (pics, triggers, controls etc. etc.) the problem appears to be tied to layers and/or objects on layers??? Clicking on layers in various slides initiates the buggy behavior, then all goes downhill quickly ... that's quite "inconvenient"!

Any "salvage content strategy" will likely have to exclude existing content on layers (and there are many, some not trivial) as I don't want a repeat of this mess.  Yes .. I've tried every avenue of NOT recreating content from scratch (cut/past into new layers - new slides -  new scenes - new project ... every combination thereof) and the problems just come along.

90% of this project was built in SL2 ... if ONLY I had a SL1 version to go back to :-(

A frustrating introduction to Version 2.

Michael Long

My problem was that I did the 30-day trial with SL2. It did install and everything was fine on my computer. The problem came when I went back to SL1 to continue my course designs, SL2 changed EVERYTHING to be viewed only by SL2. I went through and uninstalled SL2, reinstalled SL1 and it still will not view any of it's own previous files stating: "Unable to open *.story" that it was unsupported now. Quite irritating now. Hoping to not have to totally recreate a bunch of stuff.... 

If anybody has a solution to that enigma, I would greatly appreciate it.

Thanks.

Emily Ruby

Hello Michael!

Unfortunately courses created and edited in Storyline 2 cannot be reopened in Storyline 1 as it is not backwards compatible. If these were originally done in SL1, and you upgraded them, the system would have auto saved a backup SL1 file, however any changes made in SL2 will not be in the files.

 

 

Michael Long

Well, what happened was this:
I installed SL2. Then played with a newly created file. I did also test a "double-saved" SL1 version (years of mistrust of programs) to see what happened if I opened an old version with the new software. The very next time that I opened up a file folder to start working in SL1, ALL the icons had been changed to SL2 icons. Even the ones that I did not open with SL2.
Now that SL2 is off my machine, those icons will not open with, or even show as being SL1.
I didn't open all my lessons in SL2, only one that I made sure to save an extra backup of. They still were "taken over" by SL2 and now won't open with SL1.
How do we get that problem fixed? I can't go redo thousands of man-hours in SL1, and I know that since we just recently (a year or so ago) purchased SL1 that I won't be able to get them to spring for SL2. I am in a bit of a mess because SL2 took over everything having anything to do with SL.

[cid:image002.jpg@01CFEEAA.C6302A10]

Emily Ruby

Hello Michael!

 

You can right click these files and choose Open with, then select Storyline1, as long as they were not opened or upgraded to Storyline 2

Also, you can open the folder they are in, highlight the file and use the upper left hand Open button and select a default program to open these in.

 

Michael Long

I did try that as well. When I browsed to find SL1 and chose it to open the file with, it disappeared like it was going to try... and it didn't open it.

Again, I only opened one small lesson that I saved twice as SL1, with SL2. Nothing else. SL2 hijacked everything associated with Storyline at all.

[cid:image002.jpg@01CFEEAE.D69A7280]

Emily Ruby

Hello Michael!

 

As soon as you install SL2, the icons will change as it will automatically become the default. If the courses were not opened in SL2, they will still be SL1 files.

If searching  for a new default program doesn't work, you may want to try and do a repair on SL 1 to make sure everything is installed properly.