storyline 360 can't save my project (low memory error)

Hello,

I'm working on some project. I have done 5-4 slides. Sudenly SL360 starts to work very, very, very slow (almost can't do anything in it). I can't even save my project. It's happening to me few times already after working with one file for 3-4 hours. I'm sending screenshots from two errors (I'm getting those when I try to save my project). I have 32 GB of ram, so it's not a problem. I'm working on windows 10 64bit.

My slides contain: 4 photos, 15-20 buttons, 15-20 text files, few shape objects, 10-15 layers with one audio.

edit: SL360 starts working slower gradually.
When I reopen my file, it's all good and program takes only 400MB from memory. I think taht problems start when it's reaching ~3GB of RAM.

55 Replies
Ashley Terwilliger-Pollard

Hi Maciej,

Correct, Update 14 resolved a memory leak which accounts for errors folks were seeing that said things like "Available Memory is Low". You'll see this noted in the release notes for Storyline 360 as:

Fixed: Storyline could become sluggish or display a low memory error, especially after several hours of use. We found a memory leak and fixed the problem. We're so sorry for the frustration it caused. And thank you to everyone who reported it!

We still have an open issue for the performance issues that our team is working on, so we'll let you know as soon as that is resolved too.

Ross Priluker

I've been having the same problem for about a year and still no fix. Articulate promised the latest update back in March would fix the issue and it's still a problem. I've searched every forum and tried every solution and nothing works. There's forums dating back 6 years with the same exact issue. I am so frustrated right now! I work for a big marketing corporation and I can't get any work done with this bug. I've tried the whole, empty your %temp% folder thing and also emptying the  %appdata%\Articulate\Storyline  folder.... repeatedly. I can't save any work. I'm forced to start a new project in a separate window and copy the slides I worked on into that project, save it, and then restart my computer and copy those slides into the main project. And before you suggest creating a new project and importing all the slides....yes I have done that as well...problem still persists. I've aslso uninstalled and re-installed Storyline 3 repeatedly as well. This is absurd! You guys really need to get with the program and fix this issue. Storyline is unusable. I got deadlines to meet with these modules and I can't make them because this issue continues to slow me down. Don't refer me to other forums that you "claim" fixes the issue, because it doesn't. Believe me I've checked. And before you ask, "yes" all my files are local to my hard drive, I am not working off of a USB or External. I'm sick of this "low on memory" error, and "project can't be saved at this time" annoyance! Why don't we have 64 bit support yet? Also, I am running a top of the line macbook pro with VMware fusion and I have my virtual memory all the way up. No dice! I literally had to repeat the above so-called "solution" 30 times today! I can't keep doing this! I can continue to write a novel here but I think I'm finished expressing my frustration! Why my company is even spending their money on this software is beyond me at this point. It seems whenever you need to create a basic module it's fine...but then when you begin creating more heavy-duty modules, Storyline can't handle it. Please fix, and don't take 6 years to do it! Btw, I'm using the latest version of Storyline 3. 

Jihong Jin

Hi,

We ran into this issue as well in 360.

One thing I want to get better understanding: it mentioned in one of the posts above: Storyline 2 is Large-Address Aware, which means that it can access up to 4 GB RAM rather than the default limit of 2 GB for a 32-bit process.

Does it mean SL2 supports 4 GB RAM and SL360 only supports 2 GB RAM? If this is the case, I don't understand why Articulate does not make SL360 also supports 4GB RAM, since both SL2 and SL360 are 32 bit app?

Thank you very much, and I am looking forward to hearing from you soon!

Leslie McKerchie

Hi Jihong,

Great question.

The same is true for SL360 as well, so no worries there.

Now, you ran into an issue saving your project?

Ashley shared an update above, which you can read here, about some corrections being done in Update 14.

So, I'd be sure to update to the latest, which is now Update 15.

Please feel free to share your .story file and the details of the error with our team here if you're still having difficulty as we certainly want to take a look at any other performance issues.

Kenneth Ham

Add me to the pile.  Running the most current version, saving locally, & the only other applications running at this time are required business processes (background) and chrome.  Task Manager says the current memory allocation for Storyline360 process is ~400MB. Total system memory allocation for all applications, including SL360 is 2.6GB.

When I try to "Save As..." it says it can't save due to parent stream being disconnected.  When I try to save, it says low memory error and/or parent container closed.

I have to present the review draft of my project in a little less than 2.5 hours and my best hope at this point is publishing to CD and screen sharing.  However, I will have to redo all of the work I've done this morning after I present it, as I assume everything will be lost if I close this instance of Storyline360. 

I've also tried to share to team slides, in hopes that I could recover that way, but still got an error, so that wasn't an option.

Jihong Jin

Hi Leslie,

With the most recent update of SL 360 installed (v3.15.15581.0), one of my co-workers still ran into the cannot save issue with the error message mentioning low memory. What I don't understand is that, when cannot save happens:
    1) Save to another location may work, for example, instead of saving locally, saving it to a network server. However if continue the change and save to the same location, it cannot save again
    2) Save to a different file may work

If there is really a memory issue, saving to another location or saving to a different file SL 360 should require the same amount of memory, right? Does the SL 360 report the accurate error message?

And regarding what Ken mentioned about losing work, just wonder if the auto recovery copy will be available for this case (to be found in ...\AppData\...) although the user have to choose Don't Save. If not, I think we really need it.

Thank you!

Ashley Terwilliger-Pollard

Hi Jihong, 

If you're on the most recent update and still seeing the low memory error, I'd want to have you work directly with our team to look into what is happening on your end. The team is still working on overall performance issues, so it'd be helpful to have more examples of this. Can you reach out to them here and they'll provide you next steps?

The auto recovery should only take effect if Storyline crashed or otherwise closed out of the application and file. It also requires one initial save of the project. 

Tina Wilks

Any update on this SL360 issue. I just started witht eh free trial four days ago. My file is only 40MB and now when I try and swap a couple of character poses I get the low memory warning and the file won't save.

I assume as I only started with this product a couple of days ago i must have the latest version.

I'm a long time Captivate user - and have been impressed enough with Storyline to try it but I'm having serious doubts - which is a shame cos it is a real nice auhtoring tool when it behaves - but as a contractor I can't afford to mess around svaing every  few minutes and risking losing the whole porject

Ross Priluker

Hi Tina, 

Yes, I know it can be frustrating. I've experienced this as well. However with these errors and glitches, my personal opinion is that Storyline is still much better than Captivate. Our company has used Captivate in the past and from our experience, it was even more glitchy than Storyline. Whenever I get the low memory error, sometimes what works is instead of trying to save it, hit "save as" and name is as a different file. It can be something as simple as your original file name with the number 2 after it. This sometimes works for me. Also, try typing in the search bar on your pc "%temp%" and go into this folder and delete everything. Don't worry, none of your saved work will be deleted, these are just temporary files that take up memory. Another thing you can try is in Storyline, go to File --> Storyline options --> and uncheck the "Save AutoRecovery information every 10 minutes". This may help limit the number of temp files that are being created, which can take up space. Although this is not a complete fix, which I feel Articulate should be more thoroughly looking into; these are some workarounds I've found helpful in the past, hopefully they will work for some of you. 

Crystal Horn

Thanks, Tina and Ross, for sharing here.  Our team is still investigating reports of the low memory error.  We've released an update in April which has eliminated this issue for lots of users, but if you're still seeing this message, we'd love to help.  

Tina, if you're still getting stuck, can you share your experience with our support engineers?  We'll explore some specifics with you and see if we can find a good resolution.  Thanks!

Ashley Terwilliger-Pollard

Hi Louise, 

I can understand the frustration, so I'm glad you decided to also connect with our Support Team. They're in the best position to work with you one on one and figure out what exactly is going wrong and get you back to smooth sailing. I see that you're working with Christopher, so I'll follow along in case there are relevant updates to share here. 

Lindsay Feller

hi there, i am having this same issue!!!! I have lost so much work and many hours!!! very frustrating that i never know if my file is going to save or not! We just upgraded from SL3 to 360, however i was getting the low memory error in SL3, and now in 360 - very frustrating. I have tons of RAM on my computer. I have contacted our internal IT and software support and they have done as much for me as they possibly can. from reading the threads above, i will be submitting a case to support as i cannot keep losing work like this!!!!  

Louise Nicholls

Just to give you an update with me - I've moved from a desk top PC to a laptop to work from home and this issue has stopped happening so whatever the issue with, it was with that PC I was working from even though IT said there were no memory issues with my base unit. All I can say is that this issue makes you lose so many hours of work and it's beyond frustrating to have software do this when so many hours of effort go into each slide.

I hope that you resolve it for your customers very soon.

Lindsay Feller

hi Folks, thanks for all the tips! My case is finally resolved, and I found the root cause of the 'low memory' error message, file is in use error, slowness of the program, and various program crashes, due to the project file have TONS of slide masters within it. When working with the support team, he mentioned about having the file in a 'new file'. This triggered something for me, as in the case with both of my project files that were giving me troubles, they had both been old presenter files that had been imported to SL2 and then SL3, and now SL360 - well all those slide masters came with it. I had applied a 'bIank'/clean slide master to all the slides, but those masters still remain even though they aren't used. 

I eventually ended up having to copy in just text, images and audio into a brand new SL360 file so no slide master layouts came in - once I did this, no issues of the low memory error, file is in use error, or program crashes or slowness. I tried to delete the slide masters from my original working file, but it would just crash on me so given my tight deadline, I couldn't waste anymore time and just found it faster to copy and paste what I needed into a new file...... even though these projects are both approx. 200 slides (+/-). I had multiple copies of both my project files from doing 'save as' because I would get the 'file in use' message. I lost hours of work and changes because I never knew if my file would save. 

I had gone to my IT support and had them install more RAM on my computer and was working off my C: drive - I had turned off the auto-save feature to stop SL from creating tons of huge zip files. Articulate support had provided some uninstall/reinstall steps, I had just installed 360 so didn't feel that was necessary and/or part of the issue.  

So it took me some investigating but finally determined it was those darn slide masters!!! There were hundreds of slide master layouts - it was unbelievable!!

So, my advice if you run into this issue, check your file for slide masters!!!!!! and/or start with a new file. I hope this can help others who run into this issue!! 

Kristi Schultz

Wondering if there is a known fix for this issue. Just started receiving the following error yesterday. Have been working on the project for weeks with no issues. New computer with 32GB of RAM. 

HRESULT:[0X8007000W, Module: [General]. ApiCode: [E_OUTOFMEMORY/Out of Memory],Message: Not enough memory resources are available to complete this operation.

Also have see the message: The project file could not be saved. Parameter is not valid.

Katie Riggio

Hi Kristi,

I'm so sorry for the trouble and appreciate you connecting with our Support team!

After careful review, Matthew connected your experience to an open issue. For those following along

  • Behavior: The Articulate 360 Desktop displays a blank sign-in screen when installed on a device that runs on Intel's latest Iris Graphics driver. We're working hard to address this and will report back as soon as we know more.

If you're in a bind, we'd love to help you work around the problem until a fix is live. Simply open a case through this link, and we'll share the next step!

Ren Gomez
Hi Kristi,
 
Great news! We just released another update for Articulate 360!
 
The item you'll be interested in is how our new browser-based sign-in experience fixes an issue where the Articulate 360 desktop app was blank or unresponsive for people using the latest Intel processors with built-in Iris Xe graphics. You can read about the update here.
 
Just launch the Articulate 360 desktop app on your computer and click the Update button for each application. Details here.
 
Please let us know if you have any questions, either here or by reaching out to our Support Engineers directly.