Unable to edit triggers located on master slide

My colleague is suddenly unable to edit triggers in an SL 2 project with triggers and states located on the master. Does anyone know what might have caused this and what to do about it?

His description: 

Go to ‘Slide Master’ under the ‘View’ tab, click on the ‘menu’ slide layer, click on any of the picture tabs in the layer itself, go to button states (they’re all buttons), edit button states, click on ‘Selected.’ Phew.

Now, if you select the text, it has a trigger attached that takes you to a page in the course when you click on it. The problem is, ALL OF A SUDDEN, Storyline is not letting me edit those triggers anymore – I can’t even click on them at all.

I've seen the issue when I open the file on my computer, too. The triggers are all greyed out so you can't select one. The scrollbar for the list of triggers doesn't even work. It's just frozen. 

Thanks for any suggestions,

Dorothy

 


 

18 Replies
Christie Pollick

Hi, Dorothy -- Thanks for reaching out with your question! So sorry to hear of your difficulties, and you may want to take a look at this information on Unexpected or Erratic Behavior in SL2, and perhaps run through the repair steps listed in #2 to see if you find improvement. 

You are also welcome to share your file here using the ADD ATTACHMENT button in the bottom left of the reply box to browse for and upload your file. 

Or, if you need immediate or confidential assistance, you are also encouraged to create a case for review by our Support Engineers using this form. The choice is yours! 

Christie Pollick

Thanks for confirming that you are experiencing the same issues, Jason. I searched our ticketing system, Dorothy, and I did not locate a ticket for you on this issue, so if you would like to share your file once more, please be sure to provide just the .story (or source file) itself when you have a chance. :)

Dorothy Schirkofsky

Had a minute. I downloaded the attachment to see for myself. For some reason when I browse and select the .story file it uploads a bunch or unrelated files from my machine. tried a couple times with same result. 

So, I replaced the above attachment with a zip file and tested it. Seems fine. Hope you can see it now.

Jason Reed

Hi Dorothy,

The file you've uploaded worked this time. I opened it in Storyline 2 and I'm sorry to say that I can't find any issues. I can edit all of the triggers on all of the master slides. I tried clicking on each button and the associated triggers were all fine too. Sorry I couldn't be more help.

Dorothy Schirkofsky

Actually that is helpful, Jason, as it confirms the issue is not with the file. Thank you!

What OS and version are you running? We are on Windows 7 using SL 2.3.3.0.

Christie, I read the first article you linked to about reinstalling, but the fact that it's on both our computers makes me wonder if that might be a wild goose chase--and with corporate IT, an arduous one at that. Do you still recommend opening it ticket?

Christie Pollick

Hi, Dorothy -- Thanks for your patience! Sorry if this is a silly question, but I wanted to ask... when the files were initially opened, did you or your colleague happen to have received the following message and hit "No" instead of "Yes"?

Like Jason, I also had no issues editing any of the triggers from the master slides, so if possible, would you be able to share a screen recording of the steps you are taking to shed a little bit more light on the behavior you are seeing? 

Dorothy Schirkofsky

Here's a recording. When the mouse stops moving over the triggers I'm trying to double click them. You'll also see me trying to scroll the scrollbar on the Triggers panel, but it is frozen, too. At the end I go out of the states to show that the triggers at the level of the picture object are editable. It's only the triggers we have on that Selected state that are not.

This functionality was working for months prior to this.

Christie Pollick

Hi, Dorothy -- Thanks so much for the screen recording, and unfortunately, I am still not experiencing the same behavior as exhibited here, so I am going to go ahead and submit that support ticket on your behalf. You will be hearing from an engineers shortly and I'll be certain to keep tabs on their progress to share relevant updates here in the thread for others who may benefit. :)