Variables not triggering correctly

So I have created all my triggers and variables, but I seem to be missing a step. How do I trigger the calculation to mark the course completed? I have created the variable that has the logic (i.e. if all topics are equal to 1) but can't figure out how to trigger it. I am about to throw something across the room. Help please???

Project attached...

C.

8 Replies
Michael Hinze

You need to change two triggers on your slide 1.2 from When variable changes to When timeline starts. The variable is already changed on a different slide before returning to slide 1.2 and therefore these triggers would never execute. Have a look at the attached file and see if that's what you wanted.

Michele Liggett

I have a similar issue with variables and triggers. I have 6 radio buttons on my start page where the user selects which section to go to. I have added a state for each radio button of Visited showing a checkmark over the radio button. I have set up 6 different T/F variables for the radio buttons. WHen the user gets to the last slide of each section I have a "RETURN TO START" button. I have a trigger set on each of those end-of-section slides that when the user clicks Return to Start, the appropriate variable changes to true. I have a trigger set on the start page for each variable that when the variable changes then the radio button changes to Visited showing the checkmark. It works on the very first radio button, but the Visited state is not happening on any of the other radio buttons. I've compared the triggers from the first radio button with the rest and they all look the same, except with the different variable names. What am I missing?

Michael Hinze

Michele Liggett said:

I have a similar issue with variables and triggers. I have 6 radio buttons on my start page where the user selects which section to go to. I have added a state for each radio button of Visited showing a checkmark over the radio button. I have set up 6 different T/F variables for the radio buttons. WHen the user gets to the last slide of each section I have a "RETURN TO START" button. I have a trigger set on each of those end-of-section slides that when the user clicks Return to Start, the appropriate variable changes to true. I have a trigger set on the start page for each variable that when the variable changes then the radio button changes to Visited showing the checkmark. It works on the very first radio button, but the Visited state is not happening on any of the other radio buttons. I've compared the triggers from the first radio button with the rest and they all look the same, except with the different variable names. What am I missing?

Michael Hinze

@Michele, see attached a revised file where I corrected the first three radio buttons (get started, add a member, terminate as member) as follows:

- on slide 1.1 change the triggers from 'When variable changes' to 'When timeline starts' and added a condition to each trigger if variable xyz is true.

- on the last slide of a section, switched the triggers on the return button so that variable xyz is set to true before jumping back to slide 1.1

With that you should be able to fix the remaining radio buttons.

Peter Davison

Hi Michele

I think you can achieve this without using variables but the state of the button. Because you are setting the state to Selevted, this should work:

Trigger on radio buttons: Change State of Button to Visited when Timeline of the slide starts if the State of the Button is Selected.

Cheers

Peter