Weird results when using the Search field in the player

Hi there,

I've been checking over a module written by one of my colleagues and decided to test out the Search field. All seems to be working well searching for most words except when I type in the word 'quiz'. The results are displayed but the letter 'q' has been mysteriously removed from every instance of 'quiz'. I've included a snapshot to show you what I see.

Has anyone seen this before?

Other than removing the search field, is there anything I can do to fix it?

Kind regards

Julie

26 Replies
Christine Hendrickson

Hi Julie!

I had actually never seen anything like this before, but I was able to replicate it and find a possible solution.

It looks like this happens when you exclude a slide from the Menu structure. One workaround for this is to manually add or re-add the slide with the content to the Storyline menu, or add the terms to the slide notes - looks like this is case sensitive. 

Looks like we are working to get this fixed, but right now it might be best to try using one of those suggestions.

If those suggestions aren't working for you, I'd be happy to take a look a the .STORY file.

Thanks!

Deepak Lakherwal

@Ashley: Am on Storyline 02, I cannot provide you an evidence of what I am facing. My organisation's Content Policy does not allow me to share any of the course slides in any way.

Also, I am sorry for going off the topic. Why cant I upload a profile pic in my community account? I tried quite a few times yesterday and it said - Articulate is experiencing issues - and prevented me from proceeding.

Thank you for looking into this.

Leslie McKerchie

Hi Deepak! I see a profile picture for you now, so I'm assuming that part of your issue was resolved.

Are you having an issue with only one file? I would recommend that you attempt to open a new file and import your material into the new file and see if your issue is resolved. 

If not, I would recommend that you work with our support team privately and they can sign an NDA if needed for your organization.

Deepak Lakherwal

Hi Leslie,

Yeah, finally, I was able to upload the profile pic.

I seem to be facing the same issue with all the files. And as far as story file sharing is concerned, I'll try and discuss this with my organization and see if they would want to sign up an NDA with Articulate Support. 

The story files that I am working upon in Storyline 02, were originally developed in Storyline 01.

Thank you,

Deepak

Pete K

I too have come across this strange search behavior and can easily replicate it. It occurs for me when I conduct a screencast and convert the slides to step-by-step slides in View Mode using SL2 (may occur in other modes as well). When I search from the menu in the player, I often see results that show words with omitted letters. The words look misspelled but actually it's seems to be more of a bug. I can't share my project content but I can show a small screenshot of the search results (I highlighted the omitted letters).

   

Based on what others have posted as well, it seems the bug is omitting letters b, c, p, and q. Now here is where it get's really strange. When I attempt to search for the misspelled phrases that appear in the results using the Search function, I get no results (regardless of whether I spell the words correctly or not).

I also realized that the search results are showing the slide titles that are automatically generated by the step-by-step slides. So, here is the solution to resolving the odd search behavior. I simply renamed all of my slides and now the text appears correctly in the search results.

Ashley Terwilliger

Hi Pano,

Thanks for sharing that image and workaround here. You mentioned you were using Storyline 2, and I know that this was an issue fixed in Storyline 1, as a part of update 6. I'd be curious to see your sample file to take a look at what's happening. Do you only see it on screen recording slides or all slides? Are the titles correct on the slides themselves, just missing letters in the search? 

Pete K

Thanks Leslie.

Ashley, the issue only impacts the search results. None of the titles are misspelled on the slides as these are the default titles generated by the step-by-step slides from the recording. I don't recall seeing titles of non-recording slides impacted. Somehow, renaming the slides fixes the issue.

Ashley Terwilliger

Hi Sherrie, 

Are those the only letters not showing for you? Did you look at renaming the slide titles as Pano mentioned to see if that allowed it to reset and work correctly? Also, I know a workaround in Storyline 1 was to ensure the slide was included in the menu and also that you could add the slide title name to the notes as that will be included in the search as well. 

Sherrie French

Those are the 2 letters I've noticed most consistently, but I think I also saw a K missing.  I can't rename my slides because of what people would be searching for.  But then again, if they spell it right in the search and it doesn't bring up what they expect that's useless anyway. 

Thanks for your suggestions, mainly I'd just like to know when this will rise to the top of fixes to be released?

Christie Pollick

Hi, Sherrie -- Many thanks for your follow up and to answer your question, unfortunately, we are not able to announce product roadmaps or release dates for new products/features or updates. You are welcome to share your thoughts on features you'd like to see by submitting a feature request here as those go directly to our product development team.

Also, I'd suggest that you subscribe to the Word of Mouth Blog for updates on Articulate products and also follow us on Facebook or Twitter to stay up to date.  :)

Vanya Loroch

I just ran into the same bug with Storyline2. If you don't have a slide appearing in the menu  and run a search that makes it a hit, the title of that slide will miss the following characters:

J K O W  Y Z

I only tried capital letter and did not try other ASCII characters.
I run a French version of Windows with a Swiss French Keyboard, but I don't thing this would make any difference.

This is a real bug.  Can you please fix it? It is more than annoying,

I am enclosing my very complex ( :-)  ) project, just in case.

 

Hugo Chaume

Hello Vanya,

I'm using last version of SL2 and I've run throught the same problem.

I couldn't change slide title and I had to hide the slides from menu, so, I've tried the solution suggested by Christine on top of this topic. I've added the slide title in the slide notes and it solved the problem!

Hope it can help.