Rise question bank draw fail

Jun 30, 2022


I've created a bank of 36 questions and I've made a quiz, in which I've drawn 12 random questions from the bank. I get the spinning progress wheel, but it never seems to execute. I 've tried restarting the browser, and the computer, but no luck. Any ideas what may be causing this? The wheel is still spinning... (image attached).

Many thanks,


9 Replies
Hazel Bartolome

Hi Steve! So sorry to hear that you get a spinning wheel with your question bank that does not continue on.

Here are some things to try:

1. Please make sure that your browser is updated. Here are videos on how to update your browser:
For Chrome
Once updated, restart your browser and try accessing it again.
2. Try other supported browsers and check if you are still getting the issue. This will check if the issue is browser-specific.
3. Please access Rise in Incognito or InPrivate window (Windows: Press Ctrl + Shift + n. Mac: Press ⌘ + Shift + n) Sometimes plugins cause odd behavior, Do you still get the same issue when in Incognito?
4. If the above steps do not work, kindly try clearing your cache to see if it will resolve the issue. Here's how to do it.

If you've already tried all the steps above and the issue still persists, please open a case with us so that one of our technical support engineers can assist you.

Felix Franke

Same here, no response except a spinning wheel. ☹

Had a closer look at it: I tried to import the questions one by one into the course instead of letting Rise draw them and it turned out it was one specific question (a multiple-choice, in my case) which was dodgy. The import did not work for this one question.

I deleted that question and set it up from scratch, and now the automatic draw works. No idea why the one question didn't work but this was less work than writing all questions in the question bank new.

Maybe it helps someone with this problem.


I retract that statement, the question bank just stopped working entirely. No questions can be drawn from the question bank into any Rise course.

Michael Francis

Same issue, here is my resolution (apparently caused by having images attached):

  1. Removed question bank from quiz
  2. Removed images from question bank questions
  3. Added images back to questions in question bank
  4. Added question bank back to quiz
  5. Success

(fyi I had initially created questions in the quiz itself, then decided to use a question bank and copied them all - perhaps I wouldn't have had the error if built directly in the question bank - although, that defeats the benefits of being able to copy questions - also fyi that I removed and added images first and the quiz showed the questions but not the images, when I then removed the bank and re-added (as shown in my steps above) everything worked)


UPDATE: The above process only worked for one of my two question banks. Still having an issue with the second with no current workaround or fix.

Crystal Horn

Hi there, Michael and others. Thanks so much for sharing your steps for how the problem appeared, and what you did to partly resolve it.

I was not able to get caught with endless loading. To check against your process, here's what I did:

  1. Created a 3 question quiz in a new course. I used uploaded images, content library images, and added feedback to one question.
  2. Created a new question bank outside the course.
  3. Back in the course, added the 3 questions to the question bank.
  4. Created a new quiz in the course, and created a random draw with 2/3 questions from the newly created bank.

If you're still having trouble, we want to help! Please connect directly with us here, and we'll work through some next steps.

Pradeep Joshi
  • I tried the steps you mentioned, even many other ways, and finally it's solved using the below step:
  1. Removed all the .png images from the Question bank
  2. Converted all the .png images to .jpg
  3. Added back .jpg into the Question bank
  4. Draw random questions from the Question bank
  5. Done
Aaron Rose

Same problem. I don't have any images in any questions that I am trying to draw. The first bank of 5 questions I created was fine. But every other bank I have created since, no good. Just a spinning wheel. The Bank of questions is a complete waste of time, since I have to write them now. I wasted hours!

I've noticed many questionable issues with Rise and its design functionality (it's far, from a perfect development tool), but this is ridiculous)