Invalid Embed Code

I am creating an Engage interaction and I would like to insert a video from a website.  I followed the instructions and copied the embed code from this youtube video:  http://www.youtube.com/watch?v=CPEoEcs2oLs&feature=youtu.be

So I entered this as the embed code (straight from youtube site):

<iframe width="560" height="315" src="//www.youtube.com/embed/CPEoEcs2oLs?rel=0" frameborder="0" allowfullscreen></iframe>

It says that it is an invalid embed code.  What am I doing wrong?

Thanks!

Sara

7 Replies
Christine Hendrickson

Good morning Sara,

I apologize for the delay. I've been testing this, with the same code you provided as well as other codes. While I'm not seeing the invalid embed code error, I'm also running into some issues.

When I use the code you provided, as well as code for another YouTube video, it inserts properly. However, it does not play in the interaction preview, or when I preview the project in Engage '13. It also does not play after publishing and uploading to a web server or LMS. When loaded in an uploaded version, the video placeholder shows up, but there are black boarders and a blank white space.

I tested the same code from both videos in Quizmaker '13 and Storyline- just to see if they would function, and they did. 

I had a colleague of mine also test this out. He was able to confirm my results. Looks like this is limited to Engage '13, with a few interactions. I haven't tested all of them just yet, but this is definitely an issue with labeled graphic interactions. 

I have submitted a report for this issue to our QA team for additional investigation and testing. I'll also try to keep this post updated.

For now, if you need to use that video, I recommend contacting the original owner of that video to see if you can use the file itself. If not, and you have permission, you could create a screencast on Screenr.com and insert the MP4 file. This is a free service.

Another option would be to use the content in a Quizmaker '13 quiz, instead of Engage.

I apologize for the trouble, Sara. Hopefully we'll know more about this soon.

Thanks!

Tricia Wiley

Hi

I am also receiving this error when trying to use some embed code form YouTube.  Here is the code:

<iframe width="640" height="390" src="https://www.youtube.com/embed/BAbqNoxvdxM" frameborder="0" allowfullscreen></iframe>

I am trying to insert it into the Process Step template but I am receiving the same error.  I have tried adding different embed code but get the same error.  I have also tried inserting it into various other templates but none of these now seem to work!  I am using Engage 13.

Is this going to be fixed please?

Thanks

Tricia