Courses not tracking reliably on LMS

Mar 09, 2015

We have been trying for years to get our Articulate products to track reliably on our learning management system.  We even completely changed the LMS in the hope this would fix the problem. It didn't.

For example users who have completed a course will sometimes be reported as incomplete. Mostly it works, but there is a persistent minority of anomalies. They are NOT user error, by the way!

Our LMS providers tell us this is a content problem. We tried paying Articulate for advice but that got us nowhere.

Does anyone know a consultant who will look into this and help us?  We must have spent £30,000 on this problem so far, and it is undermining our whole business.

Is the answer to use some different software? Is this problem always inherent in Articulate?

10 Replies
Leslie McKerchie

Hi Bernard!

I hope that someone will be able to assist you. Looks like you were in touch with our team about a year ago (case 00389426 for my records) and you were utilizing Kalladus. 

It is hard to assist when issues cannot be reproduced. Now that you are on another LMS, perhaps testing the content on SCORM Cloud to see if it can be reproduced. If so, we could take another look and utilize those LMS debug logs that were mentioned to you last year.

Bernard George

Thanks. We are still on Kallidus, which is the third LMS we have tried, so
we suspect the problem is not with the LMS.

Kallidus say it is a content problem which must be true or at least one LMS
would have made the content report reliably.

Kallidus have managed to replicate the problem, but that is hard to do
because it does not occur all the time.

We set up a debug system last year, but that did not get us anywhere. The
idea was I think that we had to keep repeating the training until we got a
problem and then send the log. But that takes a long time. I would rather
we paid someone to investigate this for us, instead of us having to dabble
in things we do not understand.

Can you guys not take this on and investigate without us having to do all
the work ourselves? I am not a tech expert, and I am not the right person
to be doing the testing. As I have said before, I am happy to pay. But we
desperately need someone to take this on, not just to give us suggestions we
struggle to implement.


Bernard George

For Socrates Training Ltd

020 7586 6199

Mob 07772 682 492

Bernard George

Dear Leslie

Thanks.  Here is a full report so you can consider what to do next.

We are baffled why our Articulate courses do not record reliably on our Kallidus learning management system (albeit they are more reliable than they were on our two previous Moodle based systems).

Below is a summary of some of the problems we have encountered recently.  This was prepared by may assistant who handles the complaints from users.  We would be glad of your assistance in identifying what is causing these problems.

Users from numerous organisations access our training.  Problems seem to be concentrated in certain organisations. But no doubt some organisations will be better at spotting and reporting than others.

People have come up with various possible explanations. One is connection problems (possibly due to some organisations using Citrix or proxy servers). But that does not fit with our experience that some modules are much more problematic than others.

Other suggestions have been
-   User error
-   Browser issues
-   The fact that the seekbar is enabled (which does not explain quiz reporting anomalies)
-   Users using the menu to skip content (again, not consistent with quiz anomalies)

It is very unpleasant for us when users have these problems, that we cannot give any cogent explanation or ideas for what to do about them.  We desperately need support, and would be grateful for your comments. 

Regards, Bernard

Summary of data recording issues

We’ve had numerous ongoing instances over the past year where users have passed the AML Fee earners quiz and completed the separate training module, but the system records as incomplete and in progress. They’ve sometimes taken screenshots and insist that there have been no internet connectivity issues and that the modules were exited correctly. It seems that other modules have tracked correctly.  However these two problem modules are our two most heavily used, so we cannot exclude the possibility that these merely get all the failure reports for that reason.

We had the same issue last year with the Data Protection module (particularly the Data Protection quiz being passed but recording as incomplete).

One firm last year had the same issue with the AML refresher module (recorded as in progress even though completed/passed) as well as the AML Fee earners quiz.

Three firms last year had issues when users passed the AML support staff quiz – either no score recorded, or it recorded as in progress. In one instance it recorded 50% failed then 50% pass, when they had passed at 90%  - in another firm it recorded failed x 4 @ 70% and then ‘in progress’ at 0%

Nothing on those three modules so far this year.

At least one user reported that they were undergoing the AML FE training when the system froze. She went back in later and it froze again. Still it recorded as complete.

Exit button. One user at Tallents kept clicking the ‘next’ button as it wouldn’t let her use the exit button on completion of the AML FE training, she tried several times. If the slides weren’t fully viewed it would record as incomplete, but why wouldn’t the exit button work?

Franklins however is the strangest, and hasn’t come up before. As well as the same issue for one user with the AML training and quiz (where she confirmed she watched all the way through with continuity, didn’t log out and in again and had no interruptions) three reported users completed and passed modules, but the system hasn’t even recognised that they’ve logged in (AML FE training, quiz and property modules). They’ve also taken screenshots. One user initially completed these modules at home and nothing registered. He wasn’t using the proxy server at that time. He then re-took these modules at work, along with the private client module, and they all recorded fine.

Kallidus haven’t been able to replicate it, even though we created a test user for them under that domain.

Franklins use RDP, on a HYPER-V environment and have a web proxy (icritical)

Fusemail (i-critical) have confirmed that nothing is blocked.

IE11 is default browser

Bernard George

Here is another complaint in from a user today:

"I've just completed the first module of the Contract course and got to the final screen, where I got my score on the quiz (71%) and the button to finish the module and close it safely to log my progress. However,  clicking the finish button didn't do anything for ages and eventually after trying to go back a few slides/refresh the main menu, I got an error message saying I needed to debug something. Now my progress on the module has reset itself to the beginning of the presentation, and my status update on the main system has been recorded as having failed the module! Could you please advise?"

A score of 65% is a pass on this module.  The system had recorded two attempts, both scoring 14%, which it is virtually impossible to get.

What is going wrong here? It is so frustrating not being able to respond to these problems.


This discussion is closed. You can start a new discussion or contact Articulate Support.