Embedded YouTube videos not displaying in IE

Hello all,

I'm having problems with YouTube videos embedded into a presentation. The problem only seems to exist in Internet Explorer (I am using IE8 to check it - not tried with any other versions of IE). Rather than displaying the video, I get a white box with the word "advertisement" in the top left corner (see attached screenshot).

I've used the embed code from this article, which in this case is http://www.youtube.com/embed/C6OC_IJwP3o?rel=0. I think it may be a problem with the embed code, rather than anything specifically in AP, because when I visit that link in IE8 it shows the same thing.

I'd be grateful for any suggestions. Not using IE is the obvious one (as usual...) but this is unworkable as all of the PCs on campus have IE as the officially supported browser.

Thanks

Jade

UPDATE - It seems to work on some PCs with IE8 but not others. I can't find any reason why it appears differently.

6 Replies
Brian Batt

Hi Jade,

Do you own the video itself?  Or does someone else own it?  My guess is that the user has enabled advertising for the video itself:

http://support.google.com/youtube/bin/answer.py?hl=en&answer=132596

Thus, when it randomly hits an instance where it wants to show an advertisement, it gets confused on what browser you are using because you're using a non-traditional embedding method.

Christine Hendrickson

Hi there Spencer!

Not sure how Tim's question got missed, sorry about that Tim!

Can you provide a little more information about what happening, please? Are you embedding external videos, as well? Are the videos working in any browsers (Firefox, Chrome, Internet Explorer)? 

How are you publishing your presentation? Are you publishing for Web, LMS, etc.? 

Also, how are you viewing the presentation? Has it already been uploaded to a web server or LMS?

Thanks!

Christine

Tim B

There were two issues:

If you are using Vimeo,:

1) Make sure to add "s" in the Vimeo player URL prefix (so it is "https:"); and

2) Tell users of IE (v10 specifically) to go to  Tools >> Compatibility Settings and add the web site that the course is hosted on to the list of Compatible web sites.

Hope that works,

Tim