Help. My Change View Mode Button has disappeared

May 20, 2011

In my player controls for the Player Template, I have selected "Change view mode button."  Yet, it does not appear when I play the course.  What am I doing wrong?

Thanks for your help,


4 Replies
Jeanette Brooks

Hi Jill,

Couple things to check:

When you open your presentation in PowerPoint and go to Player Templates > Player Controls and mark Change View Mode Button, see what template name appears at the bottom of the window (next to the File button). Make sure that when you publish, the same player template is selected on the Publish window:

Also, the view mode toggle button will only show up if your player template is configured to allow more than one view mode. You can check that by going to Player Templates > Layout and see how many view modes are selected in the View Modes area, circled below. There will need to be at least 2 marked in order for the toggle to show up.

If you check both those things and you're still getting no toggle button, try publishing to a completely different location on your hard drive, since you might be seeing a cached version if the changes are showing up on the player.

Hope that helps!

Jill Rashdi

Hi Jeanette,

You saved the day.  Option 2 was my problem.  I only had one View Mode checked.  Actually, I unchecked some things because I was trying to display the course without the side panel.  I thought Slide view only would give me the layout I was looking for.  However, that view does not allow the course to fill up all the space; rather there is empty space on either side of the main content. Is there a way to set it up so that the content fills up the entire screen? 

Thanks for your help,


Jeanette Brooks

Even with No Sidebar and Slide Only view, the presentation will always maintain the PowerPoint slide's aspect ratio (4:3) so it may seem like there is still extra white space on the sides if the height is already as large as the player & browser window will allow. If you want the presentation to be bigger, you could always go to Player Templates > Other and change the Browser Window Settings. For example if you change the Presentation Size to "Scale presentation to fill browser window" and you change the Browser Size to "Resize Browser to Fill Screen," that will make the presentation as big as the user's monitor will allow. However, you'll probably see a loss in clarity if you do that, since everything will be scaled up, rather than being displayed at the optimal size.

Does that help?

This discussion is closed. You can start a new discussion or contact Articulate Support.