Unable to acquire LMS API Error (Oracle Learning Management)

Oct 12, 2012


We are using Articulate Presenter & Quiz maker to create our presentation & quiz in Oracle Learning Management. Recently we have created one online training and given access to all the users.

Few users are getting the error while playing the presentation in Learning Management.

"Error : Unable to acquire LMS API, content may not play properly and results may not be recorded. Please contact technical support. 

Please 'OK' to view debug information to send to technical support"

I am using IE 7 (128-bit version) and the course is running fine for me and its working fine in IE8 (256-bit version)

The users who has the following browser is getting the above error.

Safari (Version 5.1.7) , Firefox (12.0) , IE 8 with 64 bit version.


The solution is  to install the latest Java version but this could be very dangerous because some our internal applications need special Java version to be runable.

Does there exist any solution without a Java upgrade?  Could anyone can help me to solve this issue would be really great. 



29 Replies
Peter Anderson

Welcome to Heroes, Mano

Some LMSes use a Java API object to load content. Since content created in Articulate does not require Java, you can try making the following modification to your player template, and test your content again:

1)  Open your presentation in PowerPoint.

2)  Go to Articulate > Player Templates.
3)  Select the "Other" tab.
4)  Deselect (uncheck) "Launch presentation in new window".
5)  Close the Player Template manager, and save the change when prompted.
6)  Publish your presentation for LMS using the newly saved player template, and test the content in your LMS.
Brian Francom


Stumbled across this thread as I was looking for an answer to a related  problem.  I'm not sure if this is still an issue for you but Oracle did just release a SCORM adapter that doesn't require java.  There are limitations on the content servers to which it can be deployed but it might work for you.

Otherwise, the browsers you listed aren't compatible with Oracle's java based SCORM adapter with versions of java below 7.0.51 and there is nothing you will be able to do to resolve that issue other than switching to a different LMS. You might be able to find some helpful content in Oracle's OLM user group at  http://ilearning.oracle.com/ilearn/en/learner/jsp/login.jsp. Type olmug in for the site.

Hope this helps.


Michelle Fougere

Just an update this error message. The reason I received it was solely to do with a checkbox within the player. When the checkbox to launch in a new windrow, it creates a "launcher" file. In the past I could delete this file and still publish but that's not the case anymore. I have to uncheck the box. Perhaps there is a relationship to the Java version. If it's updated, this may not be an issue? I'm not sure, will have to test this out! :)

Calvin Lo

I am also experiencing this problem. Presenter project running on mobile Safari but it happens in the middle of the course and going back loses the progress i made. 

any other ideas? can't uncheck launch in new window because that's how our other courses behave and they don't experience this issue. it's just this particular course.

Ashley Terwilliger-Pollard

Hi Calvin,

If it's just this one particular course, what else is different about it? Did you publish it with a previous or newer update? Is it the only one you're accessing in Safari - is that the only place the issue occurs? As you can see this thread is also a bit older, so I'm not certain that folks are still subscribed - but I'd also advise checking with your LMS team. 

Indrani Sen

Here is a brief description of the problem  that I am experiencing. 

1.       I created and packaged a course in Articulate Storyline 2.  I don’t think anything  is wrong with the packaging. 

2.       Next I uploaded this packaged course in coursemill.  However it is not playing at all.  Here is a copy of the error message.  Just for your information, I have created courses and uploaded many times in coursemill exactly the same way, and never had this problem. 

Do you know what could be happening?



Leslie McKerchie

Hello Indrani - I'm not familiar with Coursemill. Are you able to publish and upload any course at this time or is just one course giving you difficulty? You could certainly check your browser settings as the error indicates. I would be curious if you are able to upload to SCORM Cloud. This would best tell us if there is an issue with the software/project or if it is limited to your LMS. 

If you are able to replicate, we would certainly want to take a look.

Leslie McKerchie

Hi Indrani!

You can see your publishing options for Storyline 2 within this article.

I'm assuming for Vimeo, you would need something like an mp4. Since Storyline is intended as interactive e-Learning, this is not a published output that we have built-in. 

I've heard of some users screen recording the course as they go through it if they need an mp4 format (using Replay or the screen recording functionality within Storyline).

Hopefully someone in the community will be able to chime in if they have some experience to share on this.

Christin Lundberg

Hoping my experience helps someone else. I received the "Unable to acquire LMS API Error" on our Oracle LMS. We tried everything, including digging deep into our Java situation. In the end, simply starting from scratch and creating a new course worked. I can't say for sure if the cause was related to this, but after a lot of troubleshooting, I learned that our LMS admin had adjusted the name of the course at some point. When I learned about that, I suggested we just start from scratch and delete the other course. It worked.