Numeric Type - keeps defaulting to 0 when opening question

Mar 22, 2016

How do I control what is in the numeric type answer cell that appears to the user when the question opens.  I would like a simple question mark to appear so usrs know where to enter the answer instead the cell opens with the value zero showing.   This confuses users as 0 could be an answer to the question and so they are not sure why it appears.



9 Replies
Jeff Martin

OK so the issue is more complex - if I start with a new numeric quiz slide then the answer cell remains blank when the user first sees it.  As soon as I enter any text then this question will always show a zero no matter what I do - reset etc etc to this quiz page


Now I have a work around - never ever ever try to enter anything in a numeric cell in edit screen unless you want it to show the user a zero.

But the logic I am still trying to understand is formatting of the answer cell so that when a user enters a value it has the same font size and location as other text on the page - the font selection seems stable but font size is erratic even if you turn off automatic shrink option.  You have two font sizes you can set - one b y selecting the answer box and one by first clicking in the answer box so it goes to edit mode and then setting the font size I have systematically tried all sequences and options but have yet to work out which way works - one way does but the other way does not...........


Jeff Martin

OK so font size works if you select the answer box and then set size but if you then alter something inside the box in edit mode such as centre the box appears to inherit the default font characteristics or something.  But if you do not use the centre or right or left align but use the text box setting and change the position there manually b y the px then you can move the position by changing the indent,  However I have yet to find a way to get the vertical position to be controllable.


Lesson - always set the forma on the answer box, use the setting screen for indenting - never ever enter text into the answer box.  Now you have limited control but not perfection. 


Jeff Martin

Add just when I thought I had it this is the sequence I now think works

1. add numeric type quiz page

2 Format color of box

3. Format indent position (do not bother with top and bottom value they do not work) 

4. select answer box (not inside) and set the font type and font size and bold etc

This I believe works - any other order appears to default the font size and remove bold etc


At least if this is on this forum I will be able to find my own answer next time I do it


Jeff Martin

In fact even if you alter the answer value settings they reset the font size and remove bold etc - It appears that anything to do with the answer setting resets the font size and formatting so this has to be done last and if you change any of the values you have to rest the format first and the the font size and then it works

Ashley Terwilliger-Pollard

Hi Jeff,

Yes, we have reported to our team in regards to the data entry formatting not keeping what you have set. This as you noted occurs when you click inside the field, but if you click on the box itself and make the updates to the box those formatting changes do remain. Another idea or workaround is to make the changes and lock the object on the timeline so that changes don't occur inadvertently if you click on it. 

This thread will be included in the report filed with our team so that we can update you here once available. 

This discussion is closed. You can start a new discussion or contact Articulate Support.