Articulate Mobile Player video problems

I have published a Storyline 3 file for use in Articulate Mobile Player but unfortunately I'm disappointed with the results!

Some of my slides contain more than 1 video eg there is a main video played automatically then smaller videos showing certain indicators that play when triggered by a set time on the timeline (that effectively show a zoomed in view of something on the main video that changes). It seems the AMP can only have 1 video on a slide playing at once because when one of the smaller videos plays it stops the main video! So my slides don't work even though they work perfectly in the 'preview' in Storyline. (I guess a workaround would be to put the small videos in a layer?)

Volume is set to 'mute' on the videos but in AMP the video plays with audio! I had a look at the MP4 files in the 'output' folder and found it strange these contain audio when I have set 'mute' in the Storyline file. When the video files are being encoded during publishing why not use the logic 'if volume = mute then remove audio'? (again I could workaround by going through every video and removing audio but that takes time and I expect the 'mute' option in Storyline to work)

Works ok in Flash in Internet Explorer. The HTML player for tablets is a bit 50/50; sometimes works sometimes doesn't eg videos sometimes missing, then will appear, sometimes have audio sometimes don't. Not sure if it needs a bit of buffering time hence why I want to use AMP with offline mode!

Storyline 3 Update 2, iPad Pro iOS 11.0.1 with AMP 4.1

Are these known issues? If not I'd appreciate it if someone from Articulate could investigate.

Thanks

 

 

6 Replies
Alyssa Gomez

Sorry you're running into this trouble, Daniel! Our team is happy to help. I haven't seen these AMP issues reported before, so I'd want our support engineers to have a closer look at your file. Would you mind sharing it? 

You can send it to our team privately by clicking here. We'll give it a test and reach out via email as soon as we have more to share!

Ashley Terwilliger

Hi Daniel,

Thanks for reaching out here - I'd love to help.

For the audio on the iOS device, that's a known set up and by design of iOS. iOS does not allow you to change individual videos' volume. They want you to use the hardware controls to control the volume for the entire page - so the device will override what you've set in Storyline.  One of the suggested workarounds to deal with the audio is changing the video volume to -100 instead of "mute" 

You should be able to play multiple media files in AMP but if that's not working, I'd want to take a look at your .story file to see the set up and do some testing. Can you share it with me here? If you'd prefer to share privately, you can send along to our Support Engineers as well here. 

Daniel Halliwell

Thanks for the info on iOS! Is it possible in a future update for Storyline to remove audio whilst encoding the video during publishing if mute is selected? I will try the -100 trick in the meantime.

I will send the Story file privately so you can have a look and compare Storyline preview to the AMP.

Thanks!

Daniel

Ashley Terwilliger

Hi Daniel, 

I know they looked at this issue in Storyline 1 and 2, and it was determined to be something we couldn't fix based on the iOS design. That could always change as technology changes - so I'll leave it in the hands of our Engineers/QA team. 

Thanks - I see your support case too, #  01145902 so I'll follow along!

Daniel Halliwell

Is that referring to the audio issue or multiple videos playing on one slide? Audio is easy for me to sort I guess. Multiple video if it's a limitation then I'll probably have to chunk the main video into layers to pause/continue based on the smaller videos. It's just nice to have them all play at once so it can show a zoomed in video of the lock indicators changing based on the action of the trainer in the video! I don't have the video editing software/knowledge to edit this into one video file!

daniel