Audio Restarts when Moving from Layer to Base

Hi, 

I'm am testing a course using keyboard only. On one screen you press a button to go to a layer. Pressing the button stops the audio on the base layer (which is good). When you press Enter on the button on the layer to take you back to the base (before the the audio of the layer completes) you are taken to the base but the audio of the layer restarts from the beginning and keeps playing even when you go to other layers (actually the audio restarts even if it is finished on the layer). We have tried using other key presses such as 'spacebar' and the letter 'E' and these actually stop the audio. We have put in may and varied commands to stop the audio when Enter is pressed but none work. The only time the audio stops is if you click on the button which defeats the whole accessibility function for keyboard only users.

Why would the audio on the layer you are on reset to the beginning when you exit that layer to return to the base layer when using the Enter key to activate the button that returns you to the base?

2 Replies
Lauren Connelly

Hi William!

I'm happy to see your name pop up in the forums! I hope you're well.

I've recreated this on my end, and I do not hear the audio restart. Even when I switch back and forth from the layer and base layer, the audio continues to play where it left off.

I'm attaching a sample fie to my reply. Would you mind taking a look and let me know if you have different settings on your end?

William Beardsley

Sorry that I have taken so long to get back to you but I have been off work for over a week. Thank you for the example Lauren but it is not set up the same as the example I explained above. In my example there is audio on the base and the layer. Using keyboard only the audio on the layer is continuing when returning to the base layer. I am also using buttons and not just keyboard commands. I will try and get an example to you today.