Branching scenarios not working

Sep 29, 2023


Recently (in the past 2 months) courses we produce have started showing this weird glitch when we try to build a branching scene in the course.

Often we create an interaction where the user will start on this sort of base slide with 3-4 buttons, click on one button and jump to another slide, return to the base, trigger a layer with a voice-over, and then after the VO is done and that slide hides automatically, they can click on the 2nd button, explore another slide, and come back to base.... Rinse and repeat until all buttons are visited, which will trigger a final VO-slide with an additional next button that allows the user to leave the branching scene to another topic or scene.

We produced many courses with these types of interaction and they all worked fine until recently. In some courses we produced in English at the start of the year that are now being localized, these interactions stopped working.

After the user leaves the base slide to visit the 1st button to come back and returns, the slide timeline doesn't move, play/pause button doesn't work and they can't click on any buttons.

We sent these courses to Articulate support and they got partially fixed.
Has anyone experienced anything similar with branching/VO layers? Any advice?

Thank you!

4 Replies
Nedim Ramic

Hi Karmela,

I have not experienced anything like that so far in any of my projects. You may share a sanitized version of your project and describe issues that were not fixed by the Articulate support. I'm sure someone will jump in to assist you in finding a solution to your problem or at least detect the cause. 

Karmela ID_K

Hi Nedim,

I did some more digging around in the file and it seems to me this glitch could be connected to the timeline. When I turn off the timeline visibility at the start of the branching I'm able to click on the buttons to jump on other slides. And that's only if I turn off the ''prevent the user from clicking on the other layers'' layer setting (which is kind of essential because we don't want users clicking on the buttons on the base layer before the VO stops talking)

Furthermore, elements on the layers that are supposed to appear after a couple of seconds never appear on the layers. Basically, any timeline-related events just don't happen.

I'll attach a stripped-down version of the affected course, just a couple of screens with this branching. The same thing things happens in three other places in the course and in different courses/story files too. Here is a preview link as well:

Nedim Ramic

Hi Karmela,

After reviewing your course, I found out that the slide timeline is not moving due to the Transition effect being applied on your first slide. I think it's a bug giving you a headache. I think it should be reported.  Anyway, I removed the Transition effect from the first slide only, and it seemed that it fixed the issue. Other then that, I also added one more trigger to the "Folder - 2nd return" layer: Hide layer this layer When the timeline ends on this layer (same as on the "Phone- 1st return" layer). For testing purposes, I updated a trigger on the first slide which I believe suppose to lead to the "Phone 1st return" layer if the state of Phone icon is visited. This trigger is not connected to the timeline issue. Three changes all together. Please find the attached story. Let me know if it worked for you.