Can trigger always jump to base layer? Despite Saved State??

Oct 31, 2012

Hi -

I need a slide and it's layers to save their state (stuff like visited buttons).

And, learners can leave that slide (to main menu) and then re-visit the slide: when they do, I want them to go to the base layer of that slide, not to the layer they last viewed.

Can you save a slide's state AND always navigate to its base layer??



12 Replies
Eric Matas

Hi again -

I've implemented a hack for now. I used the "Main Menu" buttons, which jump to the main menu from any slide. The "Main Menu" buttons have new triggers: to hide "this layer" when they are clicked. Thus, the saved states are preserved, and the slide is saved as showing the base layer. 

When learners re-visit the slide, they navigate to the base layer...and the visited states are saved for the already clicked buttons.

That works for now...any other ideas?

Wanda Grainer

I too have this question. I have tried adding a trigger to hide the layers so when the user returns to the main menu it will save resumed state but return to the base layer but that isn't working. It still comes back to the last layer viewed. Can anybody show me how to return to the base layer? Thank you so much!

Christine Hendrickson

Hi Wanda!

Not sure how we missed Eric's original question - sorry about that, Eric!

It really depends on how you have the project set up, Wanda. I'm guessing you want learners to come back to this slide after viewing another, correct?

Try using the revisiting setting "Reset to initial state" and see if that helps.

If not, can you share the .STORY file here? I'd be happy to take a look.


Sue Ascher


I seem to have the opposite problem! I put 2 hotspots on a layer over words in a text box and added a hover  triggert to have another layer with images pop up, but the minute I hover over the words, it reverts to the base layer. I hid all the objects (save one shape) individually, and  tried it with a rectangle instead of a hotspot as well. No luck - it always goes back to the base layer. What am I doing wrong?



Christine Hendrickson

Hi Sue,

For the trigger you've set up with the hover - does it have the option "Restore on mouse leave" enabled? If so, that may be why the layer isn't staying open. 

It should look something like this:

If that option is enabled, try disabling it by un-checking it. 

Does that solve the problem for you? If not, you're welcome to share the .STORY file here. I'd be happy to take a look.



Christine Hendrickson

Hi there Sue!

Thanks for the file :)

It looks like it may have been a combination of things, I'm not quite sure what the main issue was - but I think I have this working for you.

One thing I do want to mention though - the hotspots you were using were pretty much right where the cursor ends up after clicking on the "Compliance" object. I moved the text up on both the "Compliance" layer and the following layers to hopefully remedy this issue. It seems to be working much better.

I also removed your hotspots and used transparent shapes for the hover triggers. Hopefully this will work for you :)

Please take a look and let me know if you have any questions.

Sue Ascher

Thanks so much, Christine - that works! I had been confused since I had a very similar 'hover' on another page, and that had worked perfectly. I followed the same process with this one, but it kept jumping to the wrong layer. I think the cursor position might have a lot to do with it, although I did lower the text in your version a bit, and it still works.

One question - I'm not clear about unchecking the 'restore on mouse leave' - it almost seems counter intuitive, since I do want the layer restored when the mouse is no longer hovering. I also had it checked on the page that worked - can you explain that option?

Thanks again!!

Sue Ascher

Hi Christine,

Addendum to the above question - how do I get the Compliance (original) layer to show automatically once they've hovered? If I uncheck the 'restore on mouse click' the logos keep showing even if I move the mouse, and if I check it, then it reverts to the base layer instead of the Compliance layer...

Thanks for your patience!

Christine Hendrickson

Hi Sue,

Ahhh - I'm sorry about that. I didn't realize you wanted the layer to close after they moved their mouse off of the area. In that case, you would want that enabled. With the way you had the original hotspots set up on the layers, I was under the impression you wanted them to be able to hover over those, as well. The problem I saw with that is that they'd move their mouse to the other segment of text, but as soon as they did so, that layer would be gone. Sorry for the confusion :)

I believe the reason the base layer is showing is because of the "Hide other slide layers" option that's enabled on the "Reg" and "Accredit" layers. With this enabled, the "Compliance" layer is actually closed when another layer is opened.

I think that should fix both problems. Re-enable the "Restore on mouse leave" for the hover triggers and disable the "Hide other slide layers" option for the hover layers.

Attaching another version, if you'd like to try it out :)


This discussion is closed. You can start a new discussion or contact Articulate Support.