complete / incomplete status not reporting correctly

I have a course in storyline that is a basic reader course.  It is set to complete wtih all slides viewed.

The publish is set for LMS / Completed/Incomplete status.  However in our LMS, SumTotal, it reports as
"passed."  I have used articulate and other tools and have not had this problem. I know, normally, the status is "complete" vs "completed".  Could this be an issue with Storyline?  How is the completion status and / or where is it reported to the LMS?

thank you,

Paul

22 Replies
Paul Zamora

I was able to go into the some of the published java script files and recode parts of it and got it to report correctly to our LMS. 

The other work around is make your last slide an unreported resutls slide.  Base your completion on that results slide and the correct "Completed" parameter will work. 

Another completion issue is that we purchased a "Marked Complete" .swf widget for Articulate, which still works there.  However, it does not work in Storyline despite what the site says.  What is odd is that neither of these issues were a problem in Storyline Beta or V1 prior to the translation extension update as they were both throuroughly tested on our end.

Hopefully someone at Articulate/Storyline will have a patch for both of these. 

Melissa Scully

Hi,

Just wondering if there was any resolution for this? We use SumTotal as well and are experiencing the same issue with the LMS reporting the course as "passed" when the reporting settings in Storyline are set to "completed/incompleted". I've tested this with several different courses and get the same result.

Thanks!

Gloria Affatati

Same for us however we are using Articulate Presenter and launching with SumTotal's Pathlore LMS.  In the past 3 years all has run smooth but now our users are getting a completion letter immediately after completing the first slide. We published as SCORM 1.2 and the tracking and reporting is set to "after viewing 41 of 41 slides" with "Complete/Incomplete" as the status. Is anyone else having this problem and if so, any suggestions? At the moment it is giving credit (complete) to all who open the course.

Peter Anderson

Hi Melissa and Gloria!

Would you mind testing your course in SCORM Cloud to help us determine if the issue is Articulate-related or if it's on your LMS's side? If it appears in SCORM Cloud as well, we'd be happy to take a closer look at what might be going on. If you can't replicate the issue in SCORM Cloud, it's probably an issue that you'd want to take to your LMS team. The articles here and here may also help clear up common LMS issues.

Thanks, and I'll look forward to hearing what you come back with!

Melissa Scully

Hi Peter!

Thanks for your quick response!

I tested my course in SCORM Cloud today. I am not as familiar with its reporting but I'm attaching a screen shot of my completion results.

I see that it shows "passed" in the succes field but "complete" in the completion field. I am not sure which one is equivalent to SumTotal's Topic Status field (2nd attached screen shot).

Please let me know if you want me to proceed with submitting a support case. Thanks!

Melissa Buckmaster

Melissa & Gloria,

Did either of you ever figure out the problem to your reporting issue? I am having a similiar problem. A user is marked as "complete" whether they completed the required quiz or not. Basically they are marked complete after merely opening the course and exiting. I have checked my course on scorm cloud, but I'm not sure what it all means. The course seems to behave correctly. I purposely failed the quiz and got this report. The Completion says "complete", but Success is "Unknown".

Not sure where to go from here.

Thanks,

Paul Zamora

@ Melissa S, your SumTotal reportins is the same issue we have been experienceing all along with STL.  There is a bug in the software itself that always reports passed whether or not you choose pass/fail or complete/incomplete.  To fix that, (patch), after publishing open the LMS Folder, open the LMS.js file ---- then go to the location of change it to

This will force the LMS to report Completed where you want it.

The fix to the program has not yet been implemented. 

@Melissa B

your issue getting a completion status seems to be an incorrect Reporting / Parameters in the publish options.  You probably have it set to page completions rather than score.  The score of the quiz must also match that of the course to interact correctly.  Check the Quiz and course set up to ensure that you are passing completion based on Quiz score and not page views. 

Melissa Buckmaster

Hi Leslie,

My manager has opened a case with our LMS Cornerstone. However, I still think the Articulate side is worth investigating. I did a test. On scormcloud I tested two courses--the one that doesn't seem to report the status correctly and another one that does.

In scormcloud both courses report the same results for Complete and Success, however, they report differently in the user transcript in the LMS. I will submit a case with Articulate as I'm at wit's end.

asif raja

Hi

We have Success Factor and the the status of the course is always Incomplete

I have used the following publish settings:

scorm 1.2

HTML 5 and Mobile all ticked

Reporting to LMS status is completed/incomplete

tracking - track number of slides to 1

Any ideas how to fix this so the course can be set to complete?