Corrupt Triggers in Storyline 360

Our team is running into a new bug with our projects where the triggers and/or variables seem to be corrupting. We've seen shapes corrupt in the past and crash Storyline when interacted with, but now we're seeing perfectly correctly made triggers not activating in our published projects, without any sort of warning. Some of these triggers use JavaScript, while other use Storyline's built in trigger options.

We've tried recreating the variables and recreating the triggers, and neither of those seem to fix the problem. Importing the slides into a new project, removing all the relevant triggers and variables, and creating them again from scratch does seem to fix the problem, but it's terribly time consuming and leaves room for a lot of user error because our projects get pretty complex.

Is there a fix for this? Or anyone else experiencing this issue? We're up-to-date on the latest version of Storyline, and uninstalling/reinstalling Storyline doesn't seem to fix anything. We also can't share the project files because of client NDA's, so this explanation is the best we can do.

Thanks in advance for any help.

8 Replies
Katie Riggio

Hi there, Julia. I'm very sorry to hear you and your team are running into this!

While it's tough to track down the source of corruption, these tips can help protect your files from the risk. Like Melanie shares, saving to a local hard drive and closing Storyline daily are two of the easiest ways to protect your work. Please keep us posted!

We can also appreciate confidentiality and can sign an NDA if that works for you. Troubleshooting the file will help us get a clear picture of what's going on with the triggers and we'll delete it after. Just let us know!

Bethany Daniels

I'm glad I found this thread. I've been running into corruption issues since the latest update, specifically with sliders and results slides. The only thing that seems to remedy the issues is to completely rebuild the slides. I have been saving my files in OneDrive, so maybe that's my issue as well? I'll try saving to my hard drive instead. Thanks!

Naomi Masoner-Gould

I am currently having this same issue! I am not on a shared drive and even when I tried to rebuild from scratch my triggers are not working properly - I reached out to support about this but they have not been able to replicate the problems. So I don't know how the file could be acting weird with my computer and not on theirs. It is very frustrating, any other fixes for this found yet? 

 

Lauren Connelly

Hi Naomi!

I see that you've started working in a case with Jopney, one of our Support Engineers. That is the right step to take with corruption issues especially when they are quite specific! It looks like she's responded to your case with troubleshooting steps. We can continue investigating once we understand the nature of the error, so make sure to continue the conversation with Jopney! You're in good hands!