Corrupt variable prevents preview and publishing of slide

Here's a weird one. 

A number variable I was using to keep score for an activity seems to have corrupted a slide.

The story file in question had been published and previewed about 6 months ago. When I went into the same file to make some minor changes this morning, it would only publish half way (it only ever got up to 'Writing player...') before the error below would occur. 

Even when I tried to preview the project, the same error would occur and Storyline would crash.

I started to test each scene and then each slide individually until I found the ones causing the problem. Then, I started to delete objects on that slide and publish after each one until it stopped crashing and would finally let me preview the slide. The object that would crash the slide preview/publish every time was a text box that referenced a number variable I had named 'MediaGameSCORE' (so it was %MediaGameSCORE% in the text box).

I made a new version of the variable (named it 'GameScore') and replaced it. Now it's working fine.

I cannot figure out how a variable could corrupt a slide...! 

This is not urgent because I have replaced the file with a new version myself, but I would love to get some answers so I can avoid this mistake in the future (as it took me a good few hours to figure out what was going on!).

Attached is the old story file with the corrupt variable (try previewing or publishing, it won't work!) and the new story file with my new variable. No other changes were made. One crashes and the other doesn't. So odd.

Thanks in advance for any ideas!


2 Replies
Lauren Connelly

Hi Leanne!

I'm happy you were able recover your project! 

I viewed both, and saw exactly what you're seeing. It looks like the Release-Media-Activity-Notworking.story is corrupted. There are a multiple reasons why a file could become corrupted.

This support article explains the reasons behind corrupted projects. I keep this page bookmarked to remind myself to save all files locally and import only local files too!

Let me know if you have any questions!

Leanne Reynolds

Thanks for the reply!

It actually seems to be the variable itself that’s corrupted because I imported those slides with the variable from the original project it was in (amoung 50 other slides) and put it into this new project specifically to attach it here.

If you delete the variable from the slides it appears in, the project will work again! Give it a try if you like.

Have always worked locally and followed all those guidelines linked.

Thank you :)