Course tracking failing after certain amount of slides

Hi everyone.  I have a unique issue with a course I built for a client.  The course is comprised of 101 slides in total with tracking turned to completion when all slides are viewed.  Regardless of what browser I use the course fails to track after a specific slide (about slide 60ish).  there's nothing special about this slide.  It is a simple true false question that I have used many times throughout the course.  Loggin out and back in before I reach this slide works fine.  The LMS picks back up where from where every I left.  But once I reach this slide I get no further tracking.  Hence the course will not show completion.  I have used this template many times before and it has always tracked fine.  This is critical as it is a required course for everyone in the food industry in the state of Florida and a state requirement.  I have tested on many platforms from my mac, my pc and my ipad and it happens everytime.  I know this is a bit strange but has anyone had an issue like this before?

Thanks in advance for any responses.

Graham

9 Replies
Graham Cohen

That's good to know Phil.  I am tracking by slides.  The issue is that nothing is getting tracked after the student gets to this slide.  I know i have made bigger courses then this before and not had an issue.  There is a lot of data in this course though.  I will try changing the tracking to a final slide and see if that helps.  

Phil Mayor

I would suspect if you completed the course in one go the tracking should work, because bookmarking data is getting truncated completing in sessions is getting broken. The complete trigger would ensure you get completed courses but it will not fix the resume issue.

You can try setting as many slides to reset to initial state which reduces resume data length.

Graham Cohen

Nope.  Unfortunately even if I go through the course in one go it still stops tracking at the exact same spot.  I do agree though that this definitely sounds like a suspend.data issue due to character length.  

I found this page that explains it further.

https://articulate.com/support/article/exceeding-scorm-suspend-data-limits

My question is how do I disable the resume feature in SL360?

I'm waiting to reach the LMS manufacturer to see if they can over ride the data limits.  Hopefully that will help.  Otherwise I'll have to look at maybe going to SCORM 2004.

Graham Cohen

That is the strange issue as it passes in SCORM CLOUD just fine so I know its an LMS issue.  I could try setting the resume on restart to never but as this is a large course i'd prefer not to do that.  As the LMS is a moodle based LMS there is a possibility that there is a way to disable the suspend data limits but wont know that until i speak with them.  At least I have a working hypothesis at this point.  Thanks so much for the assistance Phil. 

Phil Mayor

You can override scorm settings in Moodle and get 64K, I wouldn't use Scorm 2004 in Moodle.

Are you tracking 100% of slides I often go 2-3% less to ensure it tracks right, particularly in Moodle 100% can fail. You may have two issues as it should still pass (especially in one setting). It maybe it is set incorrectly in moodle are you sending a score or tracking by learning objects? To get tracking right in moodle you have to set a passing score in the gradebook.