Courses not launching consistently after upgrade from XP to Win7

My team and I are experiencing some very odd behavior after upgrading from Windows XP to Windows 7. If I publish a course in Win7 and upload it to either SharePoint or our LMS it will not launch for me on my machine but will for others on the team whether they are using XP or Win7. If someone else on my team using Win7 publishes the very same SL course it will launch for everyone but them. However if — using the very same SL course — we publish it using XP it launches fine for everyone. This behavior happens to everyone on the team, i.e., if you publish a course using Win7 you won't be able to launch it but everyone else will, if you publish using XP everything is fine.

The XP machines are using IE8 while the Win7 machines are using IE9. In all cases we are publishing the courses from our C drives. (Another thing to note is that on the Win7 machines the preview functions properly for the developer; once you publish and move the file to a server the problems begin.)

Has anyone seen such behavior, and more importantly does anyone know how to fix it?

3 Replies
Ashley Terwilliger

Hi Brett,

It sounds particularly odd...with that being said, I have a few virtual machines of Win 7 and XP where I could test this as well and see if I'm able to replicate the behavior or if something occurred during the update to your computers if you'd like to share a sample .story file with us. Also, have you tested on any other servers besides SharePoint or your LMS just to rule those out? Maybe SCORM Cloud or one of the free web servers indicated in this article? 

Brett Rockwood

Hi Ashley,

Thanks for the reply. Yes, this is particularly odd. I just met with my team again to discuss and one of them mentioned that if she uploaded a course it initially wouldn't play for her but when she came back some days later it worked... I personally haven't seen this behavior as of yet and it wasn't clear how long she had to wait for it to start working.

I'm not able to access SCORM Cloud or those other servers you mentioned as our installation is tightly locked down so I can't test that way. And it doesn't seem to matter what the SL course is; anything we create in Win7 the creator is unable to view from a server but everyone else can. We consistently see this behavior with 5 copies of SL (3 on Win7 and 2 on XP).

Curiously preview works fine. When you publish it to your C drive and launch it from there it also works fine, once you allow the ActiveX control to run. It also works fine if you copy the published output to a different shared drive, i.e., not a webserver, and launch it from there.

I could send you a sample .story file but I don't think it will matter. I just created a 2 slide test course with only 1 sentence on each slide and it won't play for me.

I appreciate your help and any other suggestions you or anyone else in the community might have.

Brett

Ashley Terwilliger

Hi Brett,

It sounds like the oddness continues - I'm wondering if since conducting the update to your systems, have you tried to repair Storyline?  Did you also check to see that the appropriate Flash versions were installed with the update? I know you probably have this - but the viewing requirements and system requirements for authoring Storyline are detailed here.  Do you know if anything else was installed as a part of the update - maybe a particular program that could be interfering with your normal interactions with Storyline?