D&D mulitple tries and stopping when the try limit is reached

I have a Drag n Drop that's straightforward (3 objects to 3 specified targets).  The tries are set to 3.  If the objects are placed incorrectly, the "try again" layer appears.  Clicking on the continue button takes the learner back to the base layer of the DnD for the next try.  No probs.

But, I want the interaction to stop after x number of incorrect tries (3 in this example).  It doesn't.  The learner is redirected to the base layer and can go on forever.  I thought that specifying 3 tries in the DnD menu would solve the problem - it didn't.

I tried to set up a "tries" variable and wanted the learner to go to the incorrect layer after the "submit" button was pressed 3 times.  I can't associate a number variable with the submit button.

What am I doing wrong and what do I need to do to make it work?  Why is there air?  Why are we here?  What's the air speed of an unlaiden sparrow (European)?

7 Replies
Christine Hendrickson

Hi Alan!

The interaction sounds pretty straightforward and it sounds like you have everything set up correctly.

Not sure what's causing the issue with the attempts - are you still able to submit attempts after the third try? Or is it just taking you back to the base layer with the objects?

Are you able to share a .STORY file here, with the question slide?

Thanks!

Christine Hendrickson

I think we got the files mixed up here :D

I just responded to the other thread, thinking that file was for the feedback layer. So this one isn't previewing - just tried and I see it lock up at the very end. 

I imported this file into a new one and it seems to work now! :) 

Can you take a look and try it out for me, please?

Alan Landers

Hi Christine,

I just previewed the slide with the custom feedback slide.  Something must be corrupted in the orginial story file.  Yours works fine.  My original still hangs, I looked at the feedback master slides and saw a bunch of new slides after the one I created.  (I don't know how they got there)   I deleted them and it still hangs up.

When you say "I imported this file into a new one...", do you mean you imported the custom feedback slide into a new story or that you copied the slide and imported everthing into a new story?  I'm not sure what you did.

I really appreciate your help.  I'll try again with a new story.  This is such a simple thing.  I don't know why it did what it did, unless the story file was corrupted.

Thank you 

Christine Hendrickson

Hi Alan,

Yes, I agree, I think something broke at some point - which is a little surprising considering it's not a very "heavy" course. 

All I did was create a new, blank Storyline file. After creating the new file I went to the Articulate menu > Import > Storyline. I selected the original project file and imported the slides into the new file. 

Here's more information:

Importing from Another Storyline Project