Does anyone know how to turn off Autosave in SL2? It's driving me crazy!

May 21, 2015

Help - autosave keeps saving like every 5 minutes!  Is there any way to shut off or at least slow down the timing?  I've checked preferences and nothing!!!

Thanks in advance.



5 Replies
Christie Pollick

Hi, Tracey -- 

There was a similar thread here. Although Phil is right that it should not be affecting performance and should be invisible, if you wanted to "Save AutoRecovery information" less frequently, Jackson's suggestion would definitely work, or I'd imagine you can also uncheck the box to stop "Save AutoRecovery information" altogether. 

Otherwise, you might want to try a few things if you feel you are experiencing odd or usual behavior. Please make sure you are working locally as described here, and you may want to try importing the file into a new file. If you are still having issues, you might want to try to repair Storyline. Also, could you please ensure that you are utilizing the most recent SL2 Update? Info on Update 5 can be found here

This discussion is closed. You can start a new discussion or contact Articulate Support.