Edit Glossary Outside of Storyline

Jul 13, 2020

As much a I appreciate the update to allow a glossary to be exported and then imported into other projects, it is not doing what I expected in one respect, which is letting me add entries in Excel and then re-import.

Although I maintain all of the configuration and formatting, and the CSV format, I still get the attached error message when trying to import the glossary.

Am I doing something wrong? Is this not something Storyline does?


3 Replies
Leslie McKerchie

Hi John,

Thanks for contacting us and sharing what you're experiencing with your glossary.

Yes, I would expect that to work as well. Are you saving in one of these formats:

  • Excel for Windows:
    • CSV UTF-8 (Comma delimited)
    • CSV (Comma delimited)
  • Excel for Mac:
    • Windows Comma Separated (csv)

With your permission, I'd like to take a look at your project file to investigate what's happening. You can share it publicly here, or send it to me privately by uploading it here. I'll delete it when I'm done troubleshooting.

John Morley

Thanks Leslie,

The mystery deepens: While preparing an example to send, the glossary import worked fine; over and again as I messed with it.

But the source material lacked initial capitalization on the definitions. So I went into the CSV file and made the first letter of each definition (in the B column) a capital. Then tried to import and got the same error message I posted yesterday. On examining the CSV file, most entries had the term and definition combined in the first column: the cell in the B column is empty. Somehow this was caused during the import process.

I then tried again, capitalizing only a few entries, and it works again.

Bottom line is that it seems to work well enough for me to get by, but something is wonky and I haven't a clue as to what is triggering the wonkiness.

I am attaching a sample Storyline file, a CVS file similar to what I tried to import, and the CSV file after the failed import.


Leslie McKerchie

Thanks for the details, John.

I am unable to replicate the behavior you are experiencing.

Here's what I did:

  1. Opened your .story file to see the glossary terms
  2. Took a look at the glossary being imported - made adjustments for capitalization as you mentioned
  3. Imported the glossary into Storyline 360 and noticed that glossary updated.
  4. Exported glossary to see if the format changed.

...and everything looks good here. I'll attach my files as well.

Do you know what version of Storyline you're using?

You can check by going to:
Help > About Articulate Storyline

We are currently on Build 3.41.22450.0 of Storyline 360. You can read all of the details here.

Does this happen with any of your files or just this one?

This discussion is closed. You can start a new discussion or contact Articulate Support.