Fade in a State change

This is in response to a question that was posed earlier regarding adding fades to states in Storyline. That page seems to have been removed (at least I get a 404 error when I try to access it), but I wanted to post an updated answer an example.

The community member had noticed that when you add animations to characters (specifically he was looking at illustrated characters) they don't carry through to the states. And, he thought the "transition" was a bit too sharp and that a fade animation might help.

Phil Mayor had posted quite some time back that you CAN get this to work if you

  • Edit the state and apply the transition
  • Cut and then paste that state back in
    Check out this thread and scroll to 11/12/12

In this example I've taken a twist with that:

  • The character started out in a normal state
  • I edited that state and I applied the animation entrance: fade in very fast AND exit: fade out fast
  • Then I cut it and pasted it back in
  • I added a state, e.g., THINKING by duplicating that normal state
  • Then I deleted the image that was superimposed over the normal state on that THINKING state
    I know it sounds confusing and I'm not really sure why SL does that. But there are actually 2 images sitting here, one on top of the other. The "new" thinking image is actually sitting on top of the normal image. I "get" that it's because I duplicated the state, but I would have thought that when I said I wanted the thinking state SL would have done a replace at that point, not a copy. Anyway...
  • From the Design tab, I changed the expression to THINKING
    And, it has the animations already, but just for "safekeeping", I cut it out and pasted it back in.
  • I did this a few times for different states

And, of course, everything is tied to shapes offstage to make the transitions.

As an FYI, when I tried to do this same thing simply by creating new states rather than duplicating the normal one), I kept running into problems. It totally could have been user error, but this worked so I thought I'd post it.

3 Replies