Frame on slide in Storyline 2 prevents trigger from working

Feb 17, 2017

Hi all.

I just had a weird experience with a short, simple Storyline 2 course, whereby I for the life of me couldn't get a trigger to work.  It was just a simple "when the user clicks the button, jump to another slide" scenario.  However, no amount of editing / deleting and recreating the trigger, or deleting and recreating the control button, or use of a hotspot, or even deleting the slides involved and creating new ones with new trigger links did a thing to help.  When I clicked the button, nothing happened and I stayed on the same slide, no matter what I tried.

The slide that had the button also included a video clip that was inserted on top of a frame (shape).  When I eventually resorted to creating new slides, and adding the various elements back onto them one by one, previewing the result before adding the next item, in order to try and discover which if any of them was the culprit (have never experienced any trigger problems before on Storyline 2), it turned out that the frame under the video seemed to be the issue.  Once I removed the shape from under the video clip and just put the clip directly on top of the slide background, the link worked again!

Very weird and totally illogical, but there it was.  Any thoughts?

7 Replies
Wendy Farmer

Were you publishing to html5 or flash? Did you have triggers to hide or disable the button on timeline start then enable triggers?

I've seen this with custom buttons where a shape was partially overlapping the next button so the users area to click wasn't consistent and I've seen it with a file published to html5 but once the slide was deleted and recreated it worked.

The wonders of software ;-)

Graeme Foulds

My button was permanently visible and active on the slide, never hidden.  I had it positioned in the corner of the slide, but as there wasn't a lot of space between it and the frame, I suppose it's not impossible that they may perhaps have overlapped a tiny bit. Don't think so though.

I actually published using the CD option, in order to burn the output onto a DVD.  I guess that's still html format.

This discussion is closed. You can start a new discussion or contact Articulate Support.