Heading and body text swap when new layout applied

Hello!

Please help.

My slide master has been working fine until now, but lately when I try applying another layout to an existing slide, the heading swaps down to where the body content is, and vice-versa. Below are screen shots of the slide before and after, and of the slide layout being applied (I'm seeing this behavior regardless of which layout is applied).

I've searched in the forums and can't find info on this occurring. I've also tried recreating layouts and applying them, but the same thing happens. Shutting down and restarting Storyline doesn't do it. Other options have been tried, but to no avail.

I have a major project launch coming up and this is bogging everything down. Any clues that community members could provide will be greatly appreciated!

Thanks.

Allan

12 Replies
Steve McAneney

Interesting that the definition of a bicycle differs from State to State. You'd think a bicycle was a bicycle was a bicycle.....

I'm not sure what you're doing and what your problem is. Are you selecting your master layout when adding a new slide, then adding content to that, or adding content then changing the layout to the master slide one (which probably will cause problems)?

Allan Dunlop

Hi, Steve.

(You'd think... You would be amazed at the patchwork quilt of laws that apply to cyclists from one state to another, from one municipality to another, and within a municipality. It'd make your head spin! Some people pass through 2, 3, 4 or more sets of regulations on their daily commute.)

As for the layouts, I'm simply applying a new layout to existing content within a slide. The master has not been altered for some time, nor have the layouts, which were working without a problem until recently.

I've tried creating a new slide from a different layout and adding content; sometimes everything stays in place when I apply a different layout. Sometimes it doesn't.

Meanwhile the clock is ticking for my product release and I'm having to rebuild slides using the desired layout, rather than just applying it to the existing slide. Knowing that I may need to do many more of these, and again on the next update makes me itchy

Allan Dunlop

Sure, Hassan. Here it is.

This happens when I switch between the two layouts (Main layout / Other layout). This example file is set on 'Other layout.' Once I apply 'Main layout,' the text swaps, and reapplying the other layout doesn't get it back. This behavior has been seemingly erratic in a number of the slides with in the original file, and in others I'm working on.

Thanks for any guidance anyone can provide.

Allan

Allan Dunlop

Thanks, Nancy.

I tried that, but it still swapped the content from heading to body, and vice-versa. The only difference is that the (now) heading content was not autofit, and extended down over the body text.

This is driving me crazy. I really don't want to have to rebuild each slide (including layers and interactions) to overcome this. Any suggestions?

Hassan Mujtaba

Hi Allan,

Here is the slightly different version. This one has an image placeholder instead of an image in the slide master. 

I think the following are the reasons for text and header swapping in your file

1. Proper placeholder for title was not added in the slide master

2. The main layout master had both image and image placeholder. Only one is needed (Tip: If image is going to be different one each slide, then image placeholder. If image is same on each slide or group of slide, then image can go in slide master)

Some minor adjustments would be needed on each slide when applying these the updated layouts. Those steps would depends whether your main layout is using image placeholder or image. Let me know if you have any questions. 

Please do check the font of the new heading placeholder. I did not have exact font of my pc.

Best wishes for your project.

Hassan 

Nancy Woinoski

Allan Dunlop said:

Thanks, Nancy.

I tried that, but it still swapped the content from heading to body, and vice-versa. The only difference is that the (now) heading content was not autofit, and extended down over the body text.

This is driving me crazy. I really don't want to have to rebuild each slide (including layers and interactions) to overcome this. Any suggestions?

very strange, I tried it on your story file and it worked.
Allan Dunlop

Thanks for your help, everybody!

Nancy, that's odd that it worked for you on the file but not for me. Some strange force field going on in my office, perhaps

Hassan, I see the file you sent works fine now. Thank you. The one I had sent wasn't exactly like the one I have--there was too much proprietary content I needed to strip out, and that likely affected things.

I'll go over all of your suggestions again and try to correct the existing files. Thanks again!

Allan