Help with Menus not working

I am having the hardest time with menus in my Articulate files. I have manipulated and double checked everything, and it's still not working.

I attached some screenshots to help me articulate, here is a summary;

  • I have a menu slide with 5 icons, each icon takes the user to a separate slide, then back to the menu slide
  • Each icon has a state of "visited" when it's visited, and the icons gray out when visited
  • I have a trigger to set the next button to disabled when the icons are normal
  • I also have a trigger to set the next button to normal when the icons are visited
  • I have manipulated the properties to try Resumed saved state when revisiting, and none of these options fix it

When the user has visited all of the icons, the next button is still appearing grayed out; however, if I just test the menu slide in preview, and click all of the icons (it can't visit the target, but it'll change it to visited), then the next button will work. 

Is this an Articulate glitch? In the past I've given up and just chosen to Lightbox items, but this won't work for this training.

I am using Articulate 360, and even working off of an Articulate template for this one, so I know the menu slide is built right...

9 Replies
Alyssa Gomez

Hi Danielle! You've almost got it! You just need one change in your trigger panel.

The "Change the state of the next button to Disabled" trigger should say:

Change the state of the next button to Disabled when the Timeline Starts if the state of any of [icon 1, icon 2, icon 3...] are Normal.

Give that a try, and let me know if you see an improvement!

Katie Riggio

Hi, Danielle. Appreciate you sharing your source file for testing!

I'm seeing the same behavior, and it looks like a close match to an open issue we're currently investigating. We found that the player navigation buttons do not change states when all the necessary conditions are met.  

I'm not seeing any workarounds, but I won't give up there! While we continue to look into this oddity, I shared your .story file with our Support team so we can dig deeper to see what custom approaches we can offer in the meantime. Look out for an email from the team shortly, and I'll follow along!

Katie Riggio

Hey there, Justin!

Our team is continuing to investigate this problem, where I'm going to include your voice in its report. If there is any change in this bug's status, we'll share the news here!

In the meantime, are you comfortable with sharing your Storyline file? We found a project-specific workaround and would love to explore your setup to offer more tailored support. If you're able to share the course, please use this private upload link!

Lauren Connelly

Hi Craig!

We are happy to help! Have you tried saving the files to your local drive like a Documents folder? Saving to an external drive like a USB can cause corruption behavior.

If you're still running into this snag even when viewing the project on your local drive, we'll want our Support Engineers to step in. You can connect with our Support Team here.