Hiding base layer objects from other layers

I have a base page, and three layers which are accessed by clicking on tabs on the base page. On the base page, I also have a text box with four paragraphs that are animated to cue points syncing with audio. On the three layers, I have hidden the text box paragraphs in the base layer.

When I preview the page, and click on one of the tabs, the initial paragraph does not show, but subsequent paragraphs do appear at their cue points. How do I stop this from happening? Shouldn't all the text paragraphs be hidden, seeing as I've hidden them in the timeline?

Thanks for any help.

7 Replies
Christine Hendrickson

Hi there Rose,

I apologize for the delay!

I'm not quite following what's happening, but it may be because I cannot see what's happening and how each layer is set up. 

Remember that you need to hide anything from the base layer that you don't want to show in another layer, though all layers. 

If you're still having trouble with this, please consider sharing your .story file here, so we can take a peek.

Best,

Christine

Rose Jorgensen

I can't really add the .story file - it's sensitive information. But I've created a skeleton page so that I can hopefully explain it better with screencaps.

I have a base page, and three layers. Here is my base page - note the intro text box.

The three layers correspond with the tabs. I don't want the text box to show on the layers, so I've hidden it in the layer timelines:

However, when I preview the page, and click on a tab (layer), the intro text box displays:

Also, when I export this to Word, again the base page text box bleeds through the other items on the layer.

This is a real problem, as I have many of this type of page in my course. Could really do with some advice.

Thanks,

Rose

Christine Hendrickson

Hi Rose, 

Thanks for the screenshots - that does help, but it's still a bit limiting when it comes to testing this. 

What you could do is import the content that isn't confidential into a new file and share that with us here on the forums. 

Another option would be to submit a support case. All information shared through support cases with us are kept confidential. If you would like me to personally take a look, just add ::christine:: to the description of the case. This will assign both the case and file to me. 

Also, if you can, please let me know if this happens in a new file - or if this happens with any other objects you try to hide.

Best,

Christine

Rose Jorgensen

Thanks Christine,

Ok, I generated a one-slide story file, and will attach. Please note the following:

  • I did find a workaround, by adding a trigger to change the state of the text box to hidden when user clicks a tab. This is fine for this slide, but if the base layer has a lot of objects on it, then this would be a lot of triggers.
  • If you remove the three Text Box 1 triggers, you'll be able to reproduce the problem. You'll see that on all layers, I've hidden the Text Box 1 in the timeline. But then when it's previewed, you can see the text box on all layers.
  • But there is another issue, even if my only choice is to use the triggers - this will work for web output, but not for Word export. Even with the triggers, the text box is displayed on all slides. This will make it very difficult for reviews.

Thanks for any help, Christine.

Christine Hendrickson

Hi Rose,

Thanks very much for sharing the file and additional information!

I'm afraid I'm not seeing the same thing. First, I removed just the triggers that you added to change the state of the text. I previewed and as soon as I access any of the three layers, the text is hidden (per the layer options). 

I deleted all of the extra triggers and left only the "show layer" triggers for testing. I still see the same behavior when previewing - the slide loads and displays the text, but when I access a layer, the text is hidden. 

I created a short MP4 video recording of what I'm seeing - you'll see how it looks when I access all three tabs, then the second, third, etc. I'll attach the video, just in case you want to take a look.

Now, for publishing to Word, it's not going to work the same way. All content will show through when you publish to Word - including those that have been hidden from a layer. The best way to avoid this is to use the option to "Hide Base Layer" on the layer properties. This will hide all content from the base layer when you publish for Word, however, so your main design won't show through. The way around this is to place that content on the layer as well. 

Rose Jorgensen

Thanks Christine. Wow, why would it work one way for you, and another for me?

I'm going to create a video of how it works for me without the triggers, just so that you don't think I'm insane. Also, I'll try your suggestion for the Word export.

Would you know of any reason why my layers are bleeding through when I haven't set any triggers?

Christine Hendrickson

Hi Rose,

I'm not sure why - but I'd like to find out! :)

If you watched my video and what you saw is how it should appear for you, we may need to make sure that it's not a display or file issue on your machine. 

First, I would make sure you're working locally with the project file:

  • Work on your local drive (your C: drive). Working on a network drive or a USB drive can cause erratic behavior, including file corruption, loss of audio, and other unexpected behavior. 
  • You should also make sure the directory path to your project files and your published output is less than 260 characters (for example C:\Articulate).

Next, it might be a good idea to check your system DPI settings

If that doesn't do the trick, make sure that you're running the most recent version of Storyline. To find your current version, click on Help > About Articulate Storyline. If you're not running Update 5, download the update and install. After installing, try the project again to see if the text still shows through the layers. 

If you've tried all of those suggestions, it may help to run a quick repair:

Articulate Support - How to Repair Articulate Storyline

Let me know how it goes!

Best,

Christine