Hyperlinks

Hello,

I'm trying to create a hyperlink in one of my programs that links to a website. I've tried hyperlinking both the text, and then an invisible shape. For some reason, after I publish, neither hyperlink method works.

When I originally publish and choose the "view project" button, the hyperlink works fine. However, after zipping the file so I can email it to someone it does not work. (I do extract all files from the zipped file before testing)

Any ideas on how to get the hyperlink to work?

Thanks so much!

Katie

9 Replies
Christine Hendrickson

Hi Katie! Welcome to E-Learning Heros!

If you haven't already, you may want to check out this tutorial on inserting hyperlinks into Storyline. This may help ensure you have the hyperlink inserted correctly, plus there are a lot of helpful tips.

If you're still experiencing problems with the link functionality, please let us know!

Thanks!

Christine

Christine Hendrickson

Welcome to E-Learning Heroes, Laura!

Content won't always work properly if it's launched from a network drive, or locally (after it's been published). If you need to make sure your hyperlinks are working correctly, you'll want to test the content in the environment for which it's intended. 

Do you have access to a web server or LMS? If so, try uploading the course and then share the link to the course. If you need the content to be accessed locally, try publishing to CD, zip and email that content. Keep in mind, however, that you'll need to make sure the person who receives the zipped files extracts them first. 

Here's more information:

If you view published Storyline content on your local hard drive or send it to someone else to view on their local hard drive, you'll encounter security restrictions from the computer, web browser, Flash Player, and network that'll cause various features of your content to fail.
To properly test your published content and share it with others, upload it to the environment for which it was published. Please review the following article for details:
Welcome again, Laura! Let me know if you have any questions.
Thanks!
Chrsitine
Becky G

I too am having the same issue with hyperlinking a PDF file. 

Four key pieces of information:

>The file is showing up within the external folder as it should after hyperlinking it. 

>I am testing from two different published areas.  1.  My C drive and 2.  A network drive.  On my C drive I have full admin rights, so no issues there. 

>I have a text hyperlink that is going to a web page and it works fine. 

>Have not been able to get 1 document to link properly & followed hyperlinking tutorial.  Its not flash or browser or the other link would not work.  The program itself needs to go to that external folder and it is not referencing it.

I did see two scenarios when trying to get my hyperlink to work which may also be affecting the external folder reference from taking place.  They are:

1.  While in edit mode and double checking the hyperlink saved it, it would add an additional \ to the hyperlink, double from what existed.  I would edit, look at it again, save it and it would double it again.   If there were \\ two of them, then it would duplicate to 4 \\\\.   I then deleted all, typed it all back in rather than paste it and I "think" it took it, but I was afraid to edit again because I didn't want to go back into the same circle.   After publishing to HTML/HTML5, still didn't work.

2. I ran the green check mark to test where the document was.  It was completely random after saving and after publishing.  It is like it wiped its own cookies.  I even had the document one folder up from where the items are being published to.  It would go to the proper place one "check" and then wouldn't the next.  I can't control how that mechanism works.  This is an application working or not.

So, if this is a bug, then what is the work around?  Has the functionality between adding a hyperlinked document and a regular hyperlink been extensively tested?  They are working differently just from the external folder.  I am desperate to get this to work.  This is a really important piece in our modules.

Background, I have worked in Captivate for years, and Lectora, so I am not new to publishing and much more complicated programs.  Also have done web design so am familiar with basic html code.   So please let me know what further information you may need to assist or if there are some scenarioes we can try.

Thank you!  and I do love the app!

Christine Hendrickson

@Ray,

Can you tell us a little more about what happens when others try to view the file via the hyperlink? Do they receive any type of error messages, blank pages, etc.? Also, how are you publishing and distributing the course? Do you have the course uploaded to a web server, or are you sharing the course in another way?

@Becky,

First of all, welcome to the community! :) 

If possible, try not to test from your local hard drive, or your network drive. The course should be uploaded to a web server, LMS, or published to CD to test properly. As Shailesh mentioned, viewing the course locally can cause some really strange behavior due to restrictions in browsers, not rights. 

Another thing I would check would be the naming of the files you're trying to link to. I've seen some really strange behavior simply because there were extra spaces, or underscores. Try renaming the files to something short and simple, if you haven't already.

If you still have trouble with this, are you able to share one of the documents you're trying to link to? I'd be happy to test it out in a Storyline course and see if I run into the same trouble.

Thanks!

Christine

Matthew Ciocca

@ Everyone

Hi there,

I'm having the same issue with external links (pdf or work docs) not running in IE8 within a course I developed in Storyline. I know there is a known security issue in relation to this. However, if we go to “Tools-Internet Options-Security-Add the location as a trusted site-and then change the security setting to low,” then it works. Unfortunately, this is not something our clients want to do across the entire company, on every employee’s machine. Any help would be appreciated.

Christine Hendrickson

Hi there Matthew!

I agree - that seems like a tricky workaround for end users. 

Are you uploading this to a web server or LMS before testing? If not, I would try that - it could simply be that the security settings are conflicting with locally viewed published content. 

If you are uploading to a server and this is happening, unfortunately it may just be best to recommend a different version of the browser, or possibly a different browser altogether. I do realize that may not be the best solution - but if it's functioning properly outside of this particular version of Internet Explorer (without adjusting the settings) it may be the best way to ensure that learners are able to load the content properly on their end. 

Let us know how it goes! :)