Input a phone number in a software simulator - Javascript required

Hi. I don't know if anyone can help. I'm building a simulator of a piece of software for a client who needs people training on the software - and doesn't want them practicing on the live system!. We've done a few of these and Storyline works really well for this. I grab a screen, overlay it with text input boxes and then pretend to be the software.

I have one minor problem. I want to input a telephone number. The software I'm simulating doesn't parse the number it just only accepts digits. So, if I create a number variable and use a numeric entry box, this works fine. BUT when I run the simulator the entry box shows the default value of the variable i.e. '0' - the software doesn't do that. So, I'm looking for a way to get rid of that zero in the screen display.

I figure if I use a JavaScript trigger I can read the input character by character rejecting anything that's not a digit and then set a Storyline Variable (doesn't have to be a numeric variable - a text variable would work better) at the end. My limited JavaScript isn't up to that though! Any assistance would be greatly appreciated.

4 Replies
Phil Mayor

The text entry field will not work like that as the javascript will fire when the control loses focus.

Could you have a popup phone entry keyboard when they click on the control.

Although this is not a phone dealer it shows the idea.

https://360.articulate.com/review/content/241a276f-dbca-4f0d-9747-7bad5885e6ac/review

John Cooper

Hi Joe

Thanks for the question. The problem with a text entry box is that it accepts alpha characters. The software I'm simulating just ignores non-numerics - which is what the numeric entry box will do just fine. It's just the display of the '0' default value I would like to get rid of.

Hi Phil

I love the sweet shop challenge - I may use that idea at some point in a quiz. But obviously what I'm trying to do here is mimic as closely as I can the software I'm simulating.

I tried blanking out the field with a mask that disappears when you click it - which got rid of the '0' display  on the data entry screen but as soon as the mask disappears the dratted '0' appears. To be honest it's not a major problem and I may just have to accept the simulator is 'close enough' to the software it is pretending to be. I might experiment with changing states - there are some amazing, and unexpected, things you can do with states - this is how I overcame the 'drop-down' menu fields in the simulator.

Thanks again.