Internet Explorer - code to display content in 'Edge" mode for Articulate Storyline 2

We've recently found our LMS (PeopleSoft 9.1) SCORM window is hard-coded to display content via Internet Explorer in compatibility mode. To fix this would require the LMS vendor to make a global coding change. Is there a way to hard code in the IE code that will force the content to override that and display as "IE=Edge". (code: <meta http-equiv="X-UA-Compatible" content="IE=Edge">) directly in the Storyline 2 code?

I've attempted to add the IE content"IE=Edge" line of code manually into the story.html just below the header tag after publishing the course but that doesn't seem to recognize the code change when we re-test the course in the LMS. Do you have any suggestions for a work-around for this issue?

1 Reply
Lilly Davis

Adding more context to my original post to see if that may trigger some additional thoughts or suggestions to help me resolve our current issue. This is primary an issue of Brightcove hosted videos not displaying when embedded in the Articulate courses.

What we've found is when we embedded videos into our Storyline 2 course and the course is launched in our LMS using Internet Explorer (Enterprise/V11) the videos will NOT play. We've confirmed that when the LMS SCORM window launches the course with the embedded video the IE Content mode is being defaulted back to prior Compatibility modes either as 5 or 7, which is preventing the videos form playing. When we manually adjust the IE course window setting content mode to display content type as "Edge" the videos play. However, this is only a temporary fix while the course IE window is open. Each learner would need to know to reset that setting, which is not ideal. Our organization locks these settings so not an option either but it did confirm the compatibility mode is causing the issue.

The LMS Vendor has indicated this is not a change they can make since it's driven by the content development and code. Another tech support team provide the suggestion and code to force the content to display in Internet Explorer "Edge" mode:  "<meta http-equiv="X-UA-Compatible" content="IE=Edge">" indicating this should override how the browser window displays the content.

After reviewing the Storyline published files I found the code included just after the HEAD tag in the story.html page. I have tested out two modes to see if this works - both were unsuccessful:

1) first replacing the existing code: "<meta http-equiv="Content-Type" content="text/html;charset=utf-8" >"  WITH "<meta http-equiv="X-UA-Compatible" content="IE=Edge">"  

<head>
                  <meta http-equiv="X-UA-Compatible" content="IE=Edge">
               

2) second tested leaving the existing code and placing the code that forces it to IE Edge mode on top: 

<head>
                  <meta http-equiv="X-UA-Compatible" content="IE=Edge">
                   <meta http-equiv="Content-Type" content="text/html;charset=utf-8" >

Wondering if there is some other place the edits may need to be made in?

Any guidance or suggestion, would be appreciate,