Is it error?

I was adding a series of conditions on one of the triggers in my current project, and somehow I achieved strange thing in it. I don't know is it error or mistake. I am posting this thread just to know is it only me who found this or many of you know this. Please see image below.

In step one I created new condition as normally all  we do.

In step two where I was selecting Normal state,  I clicked on separator text "Buil-in" and clicked OK.

In step three "Edit condition" window showed me state Normal.

But in step four, the state displayed in the condition is "Built-in" which is not any state to on my object.

 

This is strange since separator text should not get selected. Does anyone of you know why it is so?

 

 

 

18 Replies
Parashuram Vhaval

Hi Praveen and Christie,

Sorry for the confusion, I don't have any issue in my file. Its working fine when i corrected the state selected in condition. I was just curious, How am I able to select the text highlighted in step 2, though it was not any state on my object.

Walt Hamilton:

You are right even I too can't use it in a trigger unless I create a custom state named "Built-In" but, When you add condition you can encounter this issue.

I am attaching one sample file for reference to all, please check trigger condition on button. My button has no state named "Built-in" but its there in condition. Since I clicked on the gray bar, instead of selecting any state. Just like in step 2.

Hope this clears my question.

Praveen Dixit

Hi Parashuram,

I have checked your story file and surprise to saw that has happened to you. I think you need to uninstall SL 2 and reinstall it again. The reason behind it is below

When I open your file and the trigger condition. It's showing the Build in.

But after I am changing it then it starts from Normal state and all. I think this will help you.

Or you can check the same file on another machine which has SL2 installed and experience what I am trying to explain.

Parashuram Vhaval

Hey Praveen,

Thanks for update. I guess now you are on right point. Have you tried to recreate this issue by selecting that gray text in your file? does it happening to you? Not in my file, please try recreating it in new file. Because I tried this on seven different machines, and surprisingly result is same every-time.  

Christie Pollick

Hi, All -- Just thought I would stop in with an update on the case Parashuram had submitted on 2/17/16. Our engineers had the following to share:

"Hi Parashuram, 

Thanks for contacting Articulate Support! 

I understand that the "Built-in" label for the states is being selected when you add a condition to your trigger. 

Thank you for uploading your project file(s). We have reviewed your project file(s) and we were able to duplicate your issue. I have submitted your case to our Quality Assurance team for their review. Unfortunately I was unable to determine a workaround. I cannot offer a time frame for when or if this issue will be resolved. 

Let me know if you need anything else!"

Ashley Terwilliger

Hi Walt,

Just wanted to let you know I did report this to our QA team - as it's odd behavior for sure. But, the results variables are not designed to be accessible and it does seem that even when you add that trigger in, it doesn't do anything - so at least that's working as we'd expect. I wouldn't think you should be able to add it though - so that's the part we've shared with our team and we'll update here once there is any other info.

Good catch!