Is There a Way To Customise the 'Review Quiz' Navigation?

Hi everyone

I have built a course that has custom navigation built into the slides, and the default Next/Previous/Submit buttons are switched off throughout the course. This has worked extremely well, until I have tried to build a custom function that allows the learner to 'review quiz'.

For the question slides themselves, I set up a trigger to hide the text box that acts as the 'submit interaction' button when the timeline of the correct/incorrect layer starts. This is does with no problem. There is also a text box on the base layer that has a 'next slide' trigger attached to it with an initial state of hidden. I have a trigger of 'change state to normal' attached to it once the learner presses the 'continue' button on the correct/incorrect layer. 

What I hoped would happen would be when the learner reviewed their quiz the custom text box for 'Submit' would disappear from the slides, and my text box that acts as the 'Next' button would be there. But regardless of where I put the triggers in the hierarchy, the submit text box remains and the next text box is still hidden when you go back and review the quiz. I have tried moving both triggers to the base line, but with the same result.

I know that I could activate the player 'Submit', 'Next' and 'Previous' buttons only for the assessment slides, but this creates the effect of having a large empty black box at the bottom of the page for the actual course slides themselves. It is not, unfortunately, an option for me to have the assessment sitting separately from the main body of the course - it needs to a be a scene within it. 

So ... does anyone have any ideas if what I am looking to achieve is possible? 

Many thanks in advance for any help.

5 Replies
Indrani Sen

Leslie,

I have an interesting problem which I have not seen before. My quiz works perfectly until the user clicks the 'review quiz' button.  For the 'Review' section, the 'correct' response shows as expected.  However, the 'next' or 'prev' button is not available which makes it difficult for the user to progress to the 'next' slide.  Any help will be awesome.  I will be happy to send you the file at a secure spot.  Thanks, Indrani

Leslie McKerchie

Hi Indrani,

Thanks for reaching out and letting us know that you're running into an issue when reviewing your quiz.

With your permission, I'd like you to share your project file with our support engineers to investigate what's happening. You can share it privately by uploading it here. It will be deleted when troubleshooting is complete.

Indrani Sen

Thanks, Leslie.

I noticed that this problem happened when I was viewing this project in IE. But when after packaging, I viewed it within an LMS, the 'next' and 'previous' buttons showed up. But just in case, I will share my original file with you and your team so that we can rule out any errors from my side.

Thanks so much for your response.

Best Regards,
Indrani